Empty panels, layout revisions

RESOLVED FIXED

Status

()

Firefox for iOS
Home screen
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: tecgirl, Assigned: bkmunar)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8640896 [details]
emptyPanelExamples.zip

After some feedback let's update some visual and layout of the empty panels.

1) Return to visually centering—not actually centering the content. What does this mean? Visual center is ever-so-slightly above actual center. Actual center appears too low. Compensation should be about -50px.

2) Open up the padding from 10 to 15. This will necessitate an overflow of the button on Remote Tabs so the button will flow to the right like we do for Error pages (at least in landscape on the 5 and above).

3) Increase EmptyStateTitleFont, EmptyStateInstructionsFont, WelcomeScreenHeaderFont, TitleLabelFont by 3 exclusively for iPad (button size and text remain).

4) Adjust WelcomeScreenHeaderFont from 14 to 15. 

5) Adjust WelcomeScreenItemTextColor from UIColor.lightGrayColor() to UIColor.grayColor()


I've attached some mocks for comparison.
(Reporter)

Updated

2 years ago
Assignee: nobody → bmunar
tracking-fxios: --- → ?
(Reporter)

Comment 1

2 years ago
6) Add UIFontWeightLight to WelcomeScreenItemFont
(Reporter)

Updated

2 years ago
Blocks: 1183213

Comment 2

2 years ago
Problem with #1, this cuts the reader panel off when rotated :o
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1188016
tracking-fxios: ? → +
(Assignee)

Comment 4

2 years ago
Created attachment 8642596 [details] [review]
PR - i know will have nits, plz halp LOL
Attachment #8642596 - Flags: ui-review?(randersen)
Attachment #8642596 - Flags: review?(bnicholson)
(Reporter)

Comment 5

2 years ago
Comment on attachment 8642596 [details] [review]
PR - i know will have nits, plz halp LOL

All good!
Attachment #8642596 - Flags: ui-review?(randersen) → ui-review+
Comment on attachment 8642596 [details] [review]
PR - i know will have nits, plz halp LOL

On the right track, but I'd like this to be more Auto Layout-friendly so this is easier to maintain. In particular, see if you can remove the device-specific constraints, and try to avoid remaking constraints where possible.
Attachment #8642596 - Flags: review?(bnicholson) → feedback+
(Assignee)

Updated

2 years ago
Attachment #8642596 - Flags: review?(bnicholson)
Attachment #8642596 - Flags: review?(bnicholson) → review+
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.