[Aries] When you share a video to message, the device will back to homescreen.

VERIFIED FIXED in Firefox 45, Firefox OS v2.5

Status

()

Core
DOM
P2
major
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Annabelle, Assigned: sotaro)

Tracking

({regression})

unspecified
mozilla45
ARM
Gonk (Firefox OS)
regression
Points:
---

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox45 fixed, b2g-v2.2 unaffected, b2g-v2.5 fixed, b2g-master verified)

Details

(Whiteboard: permafail)

Attachments

(10 attachments, 2 obsolete attachments)

(Reporter)

Description

3 years ago
Created attachment 8640946 [details]
Bug log: logcat_2119.txt

[1.Description]:
[Aries][v2.5][Flame][v2.5][Video] When you share a video with message, the device will back to  homescreen at once.
Found time:21:19
See attachment:Aries_2.5.3gp. & logcat_2119.txt

[2.Testing Steps]: 
Premise: There is a video at least.
1.Launch Video.
2.Share it with message or bluetooth.(I use message)
3.Tap "ok" after the device prompts that the file exceeds size.

[3.Expected Result]: 
3.It should stay in video view.

[4.Actual Result]: 
3.The device backs to homescreen at once.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150728035120
Gaia Revision          14e32276025b0310d3e89027320cf4b2a24cedfb
Gaia Date              2015-07-27 16:43:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150728.033538
Firmware Date          Tue Jul 28 03:35:46 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(unaffected)
Build ID               20150729152503
Gaia Revision          8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gaia Date              2015-07-29 14:28:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2a82fd90bc5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.185252
Firmware Date          Wed Jul 29 18:53:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5(Affected)
Build ID               20150729150205
Gaia Revision          088f350b39baf8f86c7c1161fd4be178ce822b7b
Gaia Date              2015-07-29 15:33:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/62cd40885e93
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.183952
Firmware Date          Wed Jul 29 18:40:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]
If I change the device(FlameKK v2.5) memory to 512/1024MB, the bug still exists.
(Reporter)

Comment 1

3 years ago
Created attachment 8640949 [details]
Bug video: Aries.3gp
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
[Blocking Requested - why for this release]:
Major/regression issue, serious impact for user, nominate.
blocking-b2g: --- → 2.5?
Keywords: regression
Keywords: regressionwindow-wanted
Hi Ethan,
Can you help to dispatch this to right owner?
Flags: needinfo?(ettseng)
QA Contact: jmercado
The changes for Bug 1144132 seem to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150622170244
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 2ab4034b2cc1
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150623190325
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 5a3ee6baf143
Version: 41.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 5a3ee6baf143

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 2ab4034b2cc1

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/c4d3b8fd78bcd7eff1b127060ec6490a891b7a35...eb0d4aefa62b20420d6fa0642515a110daca5d97
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
No-Jun, can you take a look at this please? This looks to have been caused by the landing for bug 1144132.
Blocks: 1144132
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(npark)

Comment 6

3 years ago
(In reply to KTucker [:KTucker] from comment #5)
> No-Jun, can you take a look at this please? This looks to have been caused
> by the landing for bug 1144132.

Cancel my needinfo since there is already a clue.
Thank you KTucker. :)
Flags: needinfo?(ettseng)
ni?ing gsvelto based on Comment 5 for double check. I agree that this should be nominated for 2.5.
Flags: needinfo?(npark) → needinfo?(gsvelto)

Updated

3 years ago
blocking-b2g: 2.5? → 2.5+

Comment 9

3 years ago
Moving it to System (please move this to the right sub-component) to get the right folks on this; Seems like a regression from changes that went into: https://bugzilla.mozilla.org/show_bug.cgi?id=1144132
Component: Gaia::Video → Gaia::System
Gabriele, any idea whats going on here?
I'm a bit puzzled, I tried to reproduce this and managed to do it only once. Afterwards I couldn't anymore. The only thing that might cause us to go back to the homescreen is that either the video app is killed (unlikely) or a visibilitychange handler was relying on the video app being visible when opening activities and now that we mark it as hidden it's closing the app or something. Anyway I'll try to reproduce again and investigate further, leaving the NI for now.
Component: Gaia::System → General
Summary: [Aries][Video] When you share a video to message, the device will back to homescreen. → [Aries] When you share a video to message, the device will back to homescreen.

Updated

2 years ago
Priority: -- → P2

Comment 12

2 years ago
I can always reproduce this bug by Annabelle's STR. As observation on WebIDE, Video app stop itself after step 3 in STR.

Build ID               20151005211038
Gaia Revision          1f226126dcba8af16c8db08556130b0bb04bb8d3
Gaia Date              2015-10-05 15:11:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/67adec79eb8a481d87721a10b2aa733020d326eb
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151005.203012
Firmware Date          Mon Oct  5 20:30:20 UTC 2015
Bootloader             s1
Component: General → Gaia::Video
This is really bizarre. I've just re-tested this on a Flame in the 319MB configuration using today's nightly build and I can't reproduce it. I tried the STR from comment 0 at least 5 times with no luck.
Flags: needinfo?(gsvelto)
Same result on aries, can't repro. My build is using gecko 84520cdcf7c2a0a4e48a61e8c0072b1728b97fc0 (git) e5effeb8e57c (hg) and gaia b2adfabd688f488bd37121692b8f892fad1472c7.
Going back to home screen may result from a crash. Probably Bug 1204622 fixed the same problem.

Comment 16

2 years ago
(In reply to Blake Wu [:bwu][:blakewu] from comment #15)
> Going back to home screen may result from a crash. Probably Bug 1204622
> fixed the same problem.

QA, please retest and close if this is no longer an issue
Keywords: qawanted

Comment 17

2 years ago
@ Annabelle,
Please retest this issue on the latest build to see if you still can reproduce it.
Thank you.
Flags: needinfo?(huxiaoyan)
Does not Repro in the following Builds.

Environmental Variables:
Device: Aries 2.5
BuildID: 20151013110851
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf


Environmental Variables:
Device: Flame 2.5
BuildID: 20151013030230
Gaia: d400cda6bf0f8b30dcf7d7d71bfa61f29a3f1588
Gecko: 607a236c229994df99766c005f9ec729532d7747
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D

Environmental Variables:
Device: Flame 2.2
BuildID: 20151006032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: fc588eb28eab
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(huxiaoyan) → needinfo?(jmercado)
Keywords: regression

Updated

2 years ago
Keywords: qawanted → regression
Flags: needinfo?(jmercado)

Comment 19

2 years ago
Based on comment 18, this bug does not reproduce anymore. If it surfaces back up, please reopen
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Comment hidden (obsolete)
Created attachment 8682414 [details]
Flame_KK_v2.6.3gp

Comment 22

2 years ago
This bug can be repro on latest build of Flame KK v2.5 & v2.6 and Aries KK v2.6 by the STR in comment 0(Use a video whose size is more than 100M to test).
Actual results: The device will back to homescreen at once.

See attachment: Flame_KK_v2.6.3gp.
Reproduce rate: 10/10.

Device: Flame KK v2.6 (Fail)
Build ID               20151102150204
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/6275cd9c71b76891f6b6585dabc687bc443ab877
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151102.182914
Firmware Date          Mon Nov  2 18:29:28 EST 2015
Fireware Date          v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.6 (Fail)
Build ID               20151103000930
Gaia Revision          7954ff0cbd794a35499a1082bed273598f82ee6f
Gaia Date              2015-11-02 17:35:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9f69202d82752e093a653a8f15b0274e347db33a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151102.233051
Firmware Date          Mon Nov  2 23:30:58 UTC 2015
Bootloader             s1

Comment 23

2 years ago
Russ, please investigate this?
Assignee: nobody → rnicoletti
Created attachment 8682806 [details]
300MB logcat

I am not able to reproduce using the latest flame build as of today, 11/3, with 319MB or 512MB. Once or twice I was able to produce similar behavior using a configuration of 300MB, although instead of going immediately to the homescreen after exiting the email app, the video app appeared for a couple of seconds and then went away. I have attached the logcat of my test.

sandking, if you can reproduce this issue, can you capture the adb logcat and attach it?

Sotaro, can you take a look at the logcat I've attached and see if you can identify why the video app terminated?
Flags: needinfo?(wangxin)
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 25

2 years ago
(In reply to Russ Nicoletti [:russn] from comment #24)
> Created attachment 8682806 [details]
> 300MB logcat

From the following, the video app seemed to be killed by lmk. If there is a dmesg log. It seems to help to conform it.

----------------------------------------------------------------------------------

D/GonkVideoDecoderManager( 1979): Decoder format changed
D/GonkAudioDecoderManager( 1979): FLUSH<<<
D/GonkAudioDecoderManager( 1979): >>>FLUSH
V/WLAN_PSA(  217): NL MSG, len[048], NL type[0x11] WNI type[0x5050] len[028]
I/GonkMemoryPressure( 2727): Checking to see if memory pressure is over.
I/GonkMemoryPressure(  209): Checking to see if memory pressure is over.
I/GonkMemoryPressure( 1979): Checking to see if memory pressure is over.
I/GonkMemoryPressure(  209): Memory pressure is over.
I/GonkMemoryPressure( 1979): Memory pressure is over.
I/GonkMemoryPressure( 2727): Memory pressure is over.
E/GeckoConsole(  209): [JavaScript Error: "TypeError: invalid 'in' operand details" {file: "resource://gre/modules/SystemAppProxy.jsm" line: 121}]
E/GeckoConsole(  209): systemApp_sendCustomEvent@resource://gre/modules/SystemAppProxy.jsm:121:1
E/GeckoConsole(  209): shell_sendCustomEvent@chrome://b2g/content/shell.js:673:5
E/GeckoConsole(  209): @chrome://b2g/content/shell.js:796:3
E/OMXNodeInstance(  202): !!! Observer died. Quickly, do something, ... anything...
E/        (  202): Destroy C2D instance
E/        (  202): Destroy C2D instance
Flags: needinfo?(sotaro.ikeda.g)
Hi Soyaro,

    I can repro this bug on latest build of Aries KK v2.6, but I am not able to reproduce using the latest flame KK v2.6 512Mb build as of today. I have capture the adb logcat and dmesg log what you want. 
    Could you please help to have a look? Thanks very much.

-------------------------------------------------------------------------------------------------------
See attachments: logcat_1159.txt and dmesg.txt.


Device: Aries KK v2.6 (master) (Fail)
Build ID               20151104004249
Gaia Revision          61918ddd9ccce104c009e873e34a0791e125753a
Gaia Date              2015-11-03 17:22:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f742b9412ed5aace90ad863b276faae0641090a8
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151104.000116
Firmware Date          Wed Nov  4 00:01:24 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][MGSEI-Triage+]
Flags: needinfo?(wangxin) → needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 29

2 years ago
(In reply to Carrie.Yang from comment #26)
> Hi Soyaro,
> 
>     I can repro this bug on latest build of Aries KK v2.6, but I am not able
> to reproduce using the latest flame KK v2.6 512Mb build as of today. I have
> capture the adb logcat and dmesg log what you want. 
>     Could you please help to have a look? Thanks very much.

I saw the logs. From attachment 8682941 [details] seems not killed by LMK. The reason of video close is not clear from them. But I also could reproduce the problem on master aries. I am going to look into the symptom.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Updated

2 years ago
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 30

2 years ago
In attachment 8682942 [details], the following message seems like to related to video app close.

> 11-04 13:44:45.055 I/Gecko   (  320): ###!!! [Parent][DispatchAsyncMessage] Error: (msgtype=0x460002,name=???) Route error: message sent to unknown actor ID

When I reproduced the problem on my device, after "Route error" message, video app process was closed by calling ContentParent::ProcessingError() and ContentParent::KillHard().
(Assignee)

Comment 31

2 years ago
It was caused by PContentPermissionRequest protocol messages' race condition.

[1] child side call PContentPermissionRequestChild::SendNotifyVisibility()
[2] parent side call PContentPermissionRequestParent::Send__delete__()
[3] parent side receive Msg_NotifyVisibility message, but actor was already deleted on parent side.
    And detect it as Route error.
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 32

2 years ago
Created attachment 8683059 [details] [diff] [review]
patch - Fix PContentPermissionRequest shutdown

By applying the patch, the problem was addressed on master aries.
Assigning to Sotaro as he is resolving this issue.
Assignee: rnicoletti → sotaro.ikeda.g
(Assignee)

Updated

2 years ago
Attachment #8683059 - Flags: review?(fabrice)
Attachment #8683059 - Flags: review?(fabrice) → review+
This caused leaks in some permissions tests: https://treeherder.mozilla.org/logviewer.html#?job_id=16885281&repo=mozilla-inbound

Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/c61d84e232a5
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 38

2 years ago
FYI diagram around RemotePermissionRequest:
 https://github.com/sotaroikeda/firefox-diagrams/blob/master/dom/dom_base_RemotePermissionRequest_FirefoxOS_2_5.pdf
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Updated

2 years ago
Component: Gaia::Video → DOM
Product: Firefox OS → Core
(Assignee)

Comment 39

2 years ago
Created attachment 8684533 [details] [diff] [review]
patch - Fix PContentPermissionRequest shutdown

Fix memory leak.
Attachment #8683059 - Attachment is obsolete: true
(Assignee)

Comment 41

2 years ago
Comment on attachment 8684533 [details] [diff] [review]
patch - Fix PContentPermissionRequest shutdown

Carry "r=fabrice".
Attachment #8684533 - Flags: review+

Comment 43

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4d69fc402b86
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
(Assignee)

Updated

2 years ago
status-b2g-v2.5: --- → affected
(Assignee)

Comment 45

2 years ago
Comment on attachment 8684533 [details] [diff] [review]
patch - Fix PContentPermissionRequest shutdown

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: application could be killed at unintended timing like this bug.
Testing completed: locally tested.
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: none.
Attachment #8684533 - Flags: approval‑mozilla‑b2g44?
(Assignee)

Comment 46

2 years ago
From the analysis, bug 1144132 was not a cause of this bug.
No longer blocks: 1144132
Comment on attachment 8684533 [details] [diff] [review]
patch - Fix PContentPermissionRequest shutdown

Approved for 2.5

Thanks
Attachment #8684533 - Flags: approval‑mozilla‑b2g44? → approval‑mozilla‑b2g44+

Comment 48

2 years ago
Created attachment 8686433 [details]
Verified video: Aries_v2.6.3GP

This bug has been verified as pass on latest Flame v2.6 and Aries KK v2.6.
STR:
Same STR with the attachment on comment 21.

Actual result: The device does not back to Homescreen.
See video:"Aries_v2.6.3GP"

Flame v2.6 512M(pass):
Build ID               20151111150236
Gaia Revision          22f8023b112dfae83531b0a075ab9eb9a5444dfa
Gaia Date              2015-11-10 23:35:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/84a7cf29f4f14c9b359db2f7f19c0abd6a8e178e
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151111.182640
Firmware Date          Wed Nov 11 18:26:52 EST 2015
Firmware Version       V18D V4
Bootloader             L1TC000118D0

Aries KK v2.6(Pass):
Build ID               20151112014800
Gaia Revision          98f63d4cc530906fa51d839a10469006c257b998
Gaia Date              2015-11-12 02:03:26
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/a8ed7dd831d1969a5a1a8636e63bd93d6aeaf94a
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151112.011957
Firmware Date          Thu Nov 12 01:20:05 UTC 2015
Bootloader             s1

Updated

2 years ago
status-b2g-master: affected → verified
Whiteboard: [2.5-aries-test-run-1] → permafail
this has problem during 2.5 uplift:

grafting 313674:4d69fc402b86 "Bug 1189195 - Fix PContentPermissionRequest shutdown () r=fabrice"
merging dom/base/nsContentPermissionHelper.cpp
merging dom/base/nsContentPermissionHelper.h
merging dom/ipc/ContentChild.cpp
merging dom/ipc/ContentParent.cpp
merging dom/ipc/PContentPermissionRequest.ipdl
merging dom/ipc/TabChild.cpp
warning: conflicts while merging dom/base/nsContentPermissionHelper.cpp! (edit, then use 'hg resolve --mark')
warning: conflicts while merging dom/ipc/ContentParent.cpp! (edit, then use 'hg resolve --mark')
abort: unresolved conflicts, can't continue
(use hg resolve and hg graft --continue)
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 50

2 years ago
Created attachment 8695145 [details] [diff] [review]
patch for b2g v2.5 - Fix PContentPermissionRequest shutdown

Created a patch for b2g v2.5.
Flags: needinfo?(sotaro.ikeda.g)
  This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aries KK 2.5 by the STR in comment 0.

Actual results: It can stay in video view in step 3.
See attachment: verified_Aries KK_v2.5.3gp.
Reproduce rate: 0/10


Device: Flame KK 2.5 512mb(Pass)
Build ID               20151230174512
Gaia Revision          7a016dc992b82e3700ca18382c3b3f57be178c07
Gaia Date              2015-12-30 15:34:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/b96c539dffb4f94ec52a6704805c0444269c1f83
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151230.165528
Firmware Date          Wed Dec 30 16:55:38 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20151230174456
Gaia Revision          7a016dc992b82e3700ca18382c3b3f57be178c07
Gaia Date              2015-12-30 15:34:29
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/b96c539dffb4f94ec52a6704805c0444269c1f83
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151230.165231
Firmware Date          Wed Dec 30 16:52:39 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
status-b2g-v2.5: affected → verified
Created attachment 8703069 [details]
verified_Aries KK_v2.5.3gp

Comment 53

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/cdb510ae73f7
status-b2g-v2.5: verified → fixed
backed out for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=23764&repo=mozilla-b2g44_v2_5
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 55

2 years ago
In current b2g44, "Unused" seems not work. It needs to be replaced by "unused".
Flags: needinfo?(sotaro.ikeda.g)
(Assignee)

Comment 56

2 years ago
Created attachment 8709754 [details] [diff] [review]
patch for b2g v2.5 - Fix PContentPermissionRequest shutdown

Fix build failure.
Attachment #8695145 - Attachment is obsolete: true
Attachment #8709754 - Flags: review+
You need to log in before you can comment on or make changes to this bug.