Closed Bug 1189202 Opened 5 years ago Closed 5 years ago

[DevEdition + HiDPI] The location bar dropdown icon is too small on hover

Categories

(Firefox :: Theme, defect)

x86_64
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 42
Tracking Status
firefox40 --- wontfix
firefox41 --- verified
firefox42 --- verified

People

(Reporter: cornel_ionce, Assigned: jaws)

References

Details

(Keywords: regression)

Attachments

(1 file)

Reproduced on a Microsoft Surface Pro 2 device running Windows 10 64-bit.
It reproduces with:
* latest Nightly, 
* latest DevEdition, build ID: 20150729004002.

STR:
1. Open Firefox
2. Set the DevEdition dark theme (about:addons -> Appearance -> enable Developer Edition).
3. Hover over the dropdown icon located in the location bar.

Results:
The dropdown icon is very small on hover.

Screenshot: http://i.imgur.com/1jVHkOy.png

Notes:
* This issue only reproduces on HiDPI devices.
* Only the DevEdition dark theme is affected.
* This issue is a regression.

Regression Range:
Last-good buildID: 20150528030206
First-bad buildID: 20150529030205

Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=baa9c64fea6f&tochange=f986e55c4e0b
Not tracking DevEdition issues as part of bug 1077146.
No longer blocks: windows-10, theme-win10
Summary: [HiDPI] The location bar dropdown icon is too small on hover → [DevEdition + HiDPI] The location bar dropdown icon is too small on hover
Probably caused by bug 1023607.
Blocks: 1023607
Flags: needinfo?(jaws)
I feel like we should just use the devedition SVG for the Windows theme. The color can be easily adjusted per platform, and the shape was based on the Windows' PNG
(In reply to Tim Nguyen [:ntim] from comment #3)
> I feel like we should just use the devedition SVG for the Windows theme. The
> color can be easily adjusted per platform, and the shape was based on the
> Windows' PNG

Meant Windows version, not platform
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)
Attached patch PatchSplinter Review
Attachment #8641860 - Flags: review?(bgrinstead)
Comment on attachment 8641860 [details] [diff] [review]
Patch

Review of attachment 8641860 [details] [diff] [review]:
-----------------------------------------------------------------

This fixes the problem, thanks!
Attachment #8641860 - Flags: review?(bgrinstead) → review+
https://hg.mozilla.org/mozilla-central/rev/18785164404c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 42
Confirming the fix on latest Nightly, build ID: 20150804030204 using a MS PRO 2 device.
Status: RESOLVED → VERIFIED
Can/should we uplift to 41? Might not be worth it considering merge day is Monday and we don't care about devedition on beta, I guess...?
Flags: needinfo?(jaws)
Comment on attachment 8641860 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: bug 1023607
[User impact if declined]: UI glitch in the URL bar
[Describe test coverage new/current, TreeHerder]: manual testing
[Risks and why]: no risk, simple CSS fix
[String/UUID change made/needed]: none

There will still be a couple builds of DevEdition41 before the merge and this is a really simple fix so we should uplift it if possible.
Flags: needinfo?(jaws)
Attachment #8641860 - Flags: approval-mozilla-aurora?
Comment on attachment 8641860 [details] [diff] [review]
Patch

Verified on Nightly. Aurora+
Attachment #8641860 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I've also verified this issue on latest DevEdition, build ID: 20150811004008.
You need to log in before you can comment on or make changes to this bug.