[Aries][Video]When user relaunches "Video", the video will be paused at point of the begining.

VERIFIED FIXED in Firefox 42

Status

()

VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: wangxin, Assigned: sotaro)

Tracking

unspecified
mozilla42
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(firefox42 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-aries-test-run-1])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8640963 [details]
Bug log: logcat_2234.txt

[1.Description]:
[Aries][v2.5][Video]Have a video playing, then back to Homescreen, when user relaunches the "Video", the playing video will be paused at point of the begining.
See video:"Aries_v2.5.3GP"
See log:"logcat_2234.txt"
Found Time:22:34

[2.Testing Steps]: 
1. Launch "Video".
2. Play a video.
3. When the video is playing, press "Home" key.
4. Launch "Video" again.

[3.Expected Result]: 
4. Video paused at point where video paused after following step 3.

[4.Actual Result]: 
4. Video paused at point of the begining, If you tap the play button, the video will play at  point where video paused after following step 3.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150728035120
Gaia Revision          14e32276025b0310d3e89027320cf4b2a24cedfb
Gaia Date              2015-07-27 16:43:18
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/33dc8a83cfc0
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150728.033538
Firmware Date          Tue Jul 28 03:35:46 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(unaffected)
Build ID               20150729152503
Gaia Revision          8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gaia Date              2015-07-29 14:28:57
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/e2a82fd90bc5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.185252
Firmware Date          Wed Jul 29 18:53:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5(Unaffected)
Build ID               20150729150205
Gaia Revision          088f350b39baf8f86c7c1161fd4be178ce822b7b
Gaia Date              2015-07-29 15:33:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/62cd40885e93
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.183952
Firmware Date          Wed Jul 29 18:40:04 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
5972
(Reporter)

Comment 1

3 years ago
Created attachment 8640964 [details]
Bug video: Aries_v2.5.3GP
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Assignee)

Updated

3 years ago
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 2

3 years ago
I flashed latest master flame-kk. It also caused the problem.
(Assignee)

Comment 3

3 years ago
This seems to related to Bug 1162803. All timeupdate during dormant should be suppressed. But because of mirroring related time update, incorrect time is notified to HTMLMediaElement.
(Assignee)

Updated

3 years ago
See Also: → bug 1162803
(Assignee)

Comment 4

3 years ago
Created attachment 8641791 [details] [diff] [review]
patch - Remove worng mCurrentPosition update

The patch fixed the problem on master flame-kk.
(Assignee)

Updated

3 years ago
Blocks: 1162803
See Also: bug 1162803
(Assignee)

Updated

3 years ago
Component: Gaia::Video → Audio/Video: Playback
Product: Firefox OS → Core
(Assignee)

Updated

3 years ago
Attachment #8641791 - Flags: review?(cpearce)
Attachment #8641791 - Flags: review?(cpearce) → review+
https://hg.mozilla.org/mozilla-central/rev/f6e8002ff07d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
(Reporter)

Comment 8

3 years ago
This bug has been verified as pass on latest Aries KK v2.5.
STR:
Same STR with comment0
Actural result:Video paused at point where video paused after following step 3
Occur Rate:0/10

Device:Aries KK v2.5(pass):
Build ID               20150806003241
Gaia Revision          581de383687dc441a878d2c91a0167c6ec688fef
Gaia Date              2015-08-05 01:48:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/9801f91760d9
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150805.235801
Firmware Date          Wed Aug  5 23:58:08 UTC 2015
Bootloader             s1
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: affected → verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.