Failure in test_browser_share_link.py using Flame 319MB

RESOLVED WONTFIX

Status

Firefox OS
Gaia::UI Tests
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: Martijn Wargers (dead), Unassigned)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [319MB-Flame-Support], URL)

(Reporter)

Description

3 years ago
I saw this failure in bitbar.

http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/198/HTML_Report/
Traceback (most recent call last):
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_share_link.py", line 28, in test_browser_share_to_messages
    self.assertEqual(messages.message, self.test_url)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/messages/regions/new_message.py", line 134, in message
    return self.marionette.find_element(*self._message_field_locator).text
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 1589, in find_element
    response = self._send_message('findElement', 'value', **kwargs)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 715, in _send_message
    self._handle_error(response)
  File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 751, in _handle_error
    raise errors.lookup(status)(message, stacktrace=stacktrace)
NoSuchWindowException: NoSuchWindowException: None

PASS 	test_calendar_flick_through_months.py TestCalendar.test_calendar_flick_through_months

I can reproduce it too, although this test might sometimes pass too.
The problem is that all the apps are killed because of lmk, probably.
When I run this test with the 512 internal memory setting on the Flame, nothing gets killed and the test is passing.

I think this is related to bug 1188603.
(Reporter)

Updated

3 years ago
QA Whiteboard: [memory-failure]
(Reporter)

Updated

3 years ago
Summary: Failure in test_browser_share_link.py ,using Flame 319MB → Failure in test_browser_share_link.py using Flame 319MB
(Reporter)

Updated

3 years ago
Whiteboard: [319MB-Flame-Support]
(Reporter)

Comment 1

3 years ago
I actually haven't seen it failing on Bitbar lately, so not disabling/skip-iffing or stable=falsing unless I actually see it fail.
(Reporter)

Comment 4

2 years ago
Marking WONTFIX, sorry for the bug spam. If somebody still wants to work on this, please file a new bug for it.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.