"anti-virus" typo US/GB

VERIFIED FIXED in Thunderbird 43.0

Status

Thunderbird
Preferences
--
trivial
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Marco A.G.Pinto, Assigned: Aadithya B K, Mentored)

Tracking

Trunk
Thunderbird 43.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug])

Attachments

(2 attachments, 3 obsolete attachments)

(Reporter)

Description

2 years ago
Created attachment 8641096 [details]
Typo in options

Hello!

According to Oxford, "anti-virus" is written "antivirus":
http://www.oxforddictionaries.com/definition/american_english/antivirus
http://www.oxforddictionaries.com/definition/english/antivirus

Updated

2 years ago
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 42 → Trunk

Comment 1

2 years ago
Marco, this is a type of bugs that you could fix yourself if you downloaded the TB source tree (even without having to run the whole build).
Would you be interested in trying it?
Mentor: acelists@atlas.sk
Whiteboard: [good first bug]
(Reporter)

Comment 2

2 years ago
@aceman: How can I do it? :)

Comment 3

2 years ago
See these docs:
https://developer.mozilla.org/en-US/docs/Simple_Thunderbird_build
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Source_Code/Getting_comm-central
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites
But only the part about getting the source code. Also you have to have Mercurial (hg) installed and probably Python. You may also like some GUI tool for mercurial, e.g. TortoiseHG.

I do not ask you to install all the building tools (like a compiler).
OS: Unspecified → All
Hardware: Unspecified → All
(Assignee)

Comment 4

2 years ago
Created attachment 8649040 [details] [diff] [review]
Bug1189365_TypoFix.patch

I have attached a possible patch for this bug. I tested it and it works as expected.
Attachment #8649040 - Flags: review?(acelists)

Comment 5

2 years ago
Comment on attachment 8649040 [details] [diff] [review]
Bug1189365_TypoFix.patch

Review of attachment 8649040 [details] [diff] [review]:
-----------------------------------------------------------------

>user: aadithyabk <aadithyabk@gmail.com>
>branch 'default'
>changed mail/locales/en-US/chrome/messenger/preferences/security.dtd

Did you add these lines to the commit message?
I think usually mercurial does it like this:

# HG changeset patch
# Parent  ff5aea3e6171d1c33621066a4412ab3db6a6ff24
# User aadithyabk <aadithyabk@gmail.com>
 
Fixed the typo bug by editing the security.dtd file under mail/locales. I identified that this is the file to be editied by going through security.js under preferences. .


---

Also please make the commit message be more specific to what was done, e.g. "Replaced all 'anti-virus' words to 'antivirus' in whole of comm-central."

Looks good to me. Can you also do the Seamonkey strings in the same patch?

/suite/locales/en-US/chrome/common/help/mailnews_preferences.xhtml 

    line 580 -- <li><strong>Allow anti-virus clients to scan incoming messages more
    line 582 -- anti-virus software to analyze incoming mail messages for viruses before

/suite/locales/en-US/chrome/mailnews/pref/pref-junk.dtd 

    line 38 -- <!ENTITY pref.antivirus.caption "Anti-Virus">
    line 39 -- <!ENTITY antiVirus.label "Allow anti-virus clients to scan incoming messages more easily">
Attachment #8649040 - Flags: review?(acelists) → feedback+

Updated

2 years ago
Assignee: nobody → aadithyabk
Status: NEW → ASSIGNED
(Assignee)

Comment 6

2 years ago
When I was entering the commit message, these lines were prefixed with HG and it said lines prefixed with HG would be removed. I thought the prefix has to be removed by me. Aren't the following lines required in that case ?

>user: aadithyabk <aadithyabk@gmail.com>
>branch 'default'
>changed mail/locales/en-US/chrome/messenger/preferences/security.dtd

My commit messages will be more specific from the next time. This would by my first contribution. 

Yes, I will make those changes and upload a new patch.
(Assignee)

Comment 7

2 years ago
Created attachment 8649317 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch
Attachment #8649040 - Attachment is obsolete: true
Attachment #8649317 - Flags: review?(acelists)

Comment 8

2 years ago
Hi, Aadithya. Please, consider following these tips for configuring your Mercurial: https://developer.mozilla.org/en-US/docs/Mercurial/Using_Mercurial#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3F
(Assignee)

Comment 9

2 years ago
(In reply to :aceman from comment #5)
> Comment on attachment 8649040 [details] [diff] [review]
> Bug1189365_TypoFix.patch
> 
> Review of attachment 8649040 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> >user: aadithyabk <aadithyabk@gmail.com>
> >branch 'default'
> >changed mail/locales/en-US/chrome/messenger/preferences/security.dtd
> 
> Did you add these lines to the commit message?
> I think usually mercurial does it like this:
> 
> # HG changeset patch
> # Parent  ff5aea3e6171d1c33621066a4412ab3db6a6ff24
> # User aadithyabk <aadithyabk@gmail.com>
>  
> Fixed the typo bug by editing the security.dtd file under mail/locales. I
> identified that this is the file to be editied by going through security.js
> under preferences. .
> 
> 
> ---
> 
> Also please make the commit message be more specific to what was done, e.g.
> "Replaced all 'anti-virus' words to 'antivirus' in whole of comm-central."
> 
> Looks good to me. Can you also do the Seamonkey strings in the same patch?
> 
> /suite/locales/en-US/chrome/common/help/mailnews_preferences.xhtml 
> 
>     line 580 -- <li><strong>Allow anti-virus clients to scan incoming
> messages more
>     line 582 -- anti-virus software to analyze incoming mail messages for
> viruses before
> 
> /suite/locales/en-US/chrome/mailnews/pref/pref-junk.dtd 
> 
>     line 38 -- <!ENTITY pref.antivirus.caption "Anti-Virus">
>     line 39 -- <!ENTITY antiVirus.label "Allow anti-virus clients to scan
> incoming messages more easily">

I have submitted a new patch for review but I am not sure if the commit message is in the correct format. This time, I let the lines prefixed by HG: as is unlike last time where I had deleted the prefix. Please let me know if there is a problem and I will be happy to correct myself.
(Assignee)

Comment 10

2 years ago
(In reply to Javi Rueda from comment #8)
> Hi, Aadithya. Please, consider following these tips for configuring your
> Mercurial:
> https://developer.mozilla.org/en-US/docs/Mercurial/
> Using_Mercurial#How_can_I_generate_a_patch_for_somebody_else_to_check-
> in_for_me.3F

Thanks for the tip but I did go through these steps to configure my mercurial. Is something wrong with the configuration ?

Comment 11

2 years ago
Comment on attachment 8649317 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

Review of attachment 8649317 [details] [diff] [review]:
-----------------------------------------------------------------

There are files for /suite and for /mail here for the same patch. I think that it is preferred to split patches on a per-product basis.
Attachment #8649317 - Flags: feedback-

Comment 12

2 years ago
Comment on attachment 8649317 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

Review of attachment 8649317 [details] [diff] [review]:
-----------------------------------------------------------------

# HG changeset patch
# Parent  ff5aea3e6171d1c33621066a4412ab3db6a6ff24

Somehow it is still missing the # User line. Please check your mercurial setup.
The commit line seems fine.
Attachment #8649317 - Flags: review?(acelists) → feedback+
(Assignee)

Comment 13

2 years ago
Oh! I was just doing what I was told to. To quote :aceman from comment 5, 

"Looks good to me. Can you also do the Seamonkey strings in the same patch?"

I believe they are required to be in the same patch.

Comment 14

2 years ago
(In reply to Javi Rueda from comment #11)
> There are files for /suite and for /mail here for the same patch. I think
> that it is preferred to split patches on a per-product basis.

We seem to not follow this rule in comm-central. We just have reviewers from both products review the same patch (as often the changes are mirroring, e.g. changing the same string or feature in both products). If the patch is big or the changes not related, then we sometimes split the patch.
(Assignee)

Comment 15

2 years ago
(In reply to :aceman from comment #12)
> Comment on attachment 8649317 [details] [diff] [review]
> Bug1189365_TypoFix_V2.patch
> 
> Review of attachment 8649317 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> # HG changeset patch
> # Parent  ff5aea3e6171d1c33621066a4412ab3db6a6ff24
> 
> Somehow it is still missing the # User line. Please check your mercurial
> setup.
> The commit line seems fine.

Could you help me out ? So when I execute `hg qrefresh -e`, an editor opens up with the following contents

HG: Enter commit message.  Lines beginning with 'HG:' are removed.
HG: Leave message empty to use default message.
HG: --
HG: user: aadithyabk <aadithyabk@gmail.com>
HG: branch 'default'
HG: changed mail/locales/en-US/chrome/messenger/preferences/security.dtd
HG: changed suite/locales/en-US/chrome/common/help/mailnews_preferences.xhtml
HG: changed suite/locales/en-US/chrome/mailnews/pref/pref-junk.dtd

So, should I remove the prefix for line containing user ?

Comment 16

2 years ago
Comment on attachment 8649317 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

Review of attachment 8649317 [details] [diff] [review]:
-----------------------------------------------------------------

:aceman requested those strings for both suite and mail on the same patch. Nothing else I should say then.

Aadithya: I use Mercurial Queues so I can change the message for the patch from the command line. I don't know how to do it without MQ.
Attachment #8649317 - Flags: feedback-
(Assignee)

Comment 17

2 years ago
I would really appreciate if somebody could help me setup mercurial to include # User line which I'm missing.

Thanks!

Comment 18

2 years ago
(In reply to Aadithya B K from comment #15)
> (In reply to :aceman from comment #12)
> > Somehow it is still missing the # User line. Please check your mercurial
> > setup.
> > The commit line seems fine.
> 
> Could you help me out ? So when I execute `hg qrefresh -e`, an editor opens
> up with the following contents

Do you have this in your .hgrc file?
[ui]
username = aadithyabk <aadithyabk@gmail.com>
(Assignee)

Comment 19

2 years ago
(In reply to :aceman from comment #18)
> (In reply to Aadithya B K from comment #15)
> > (In reply to :aceman from comment #12)
> > > Somehow it is still missing the # User line. Please check your mercurial
> > > setup.
> > > The commit line seems fine.
> > 
> > Could you help me out ? So when I execute `hg qrefresh -e`, an editor opens
> > up with the following contents
> 
> Do you have this in your .hgrc file?
> [ui]
> username = aadithyabk <aadithyabk@gmail.com>

Yes, I did enter it during the setu[. I tried searching for hgrc files to see the file contents. A number of hgrc files came up during the search but none of them had my username. Could you tell me which hgrc file I should be looking at ? I mean, the path will do.
(Assignee)

Comment 20

2 years ago
(In reply to :aceman from comment #18)
> (In reply to Aadithya B K from comment #15)
> > (In reply to :aceman from comment #12)
> > > Somehow it is still missing the # User line. Please check your mercurial
> > > setup.
> > > The commit line seems fine.
> > 
> > Could you help me out ? So when I execute `hg qrefresh -e`, an editor opens
> > up with the following contents
> 
> Do you have this in your .hgrc file?
> [ui]
> username = aadithyabk <aadithyabk@gmail.com>

I checked out the console output while executing `mach mercurial-setup` command, it is writing to a file called mercurial.ini in C:\Users\

Comment 21

2 years ago
I am on Linux and the file is called .hgrc (also with the dot), and it is in my user home folder. Not in the Thunderbird source tree.
(Assignee)

Comment 22

2 years ago
Created attachment 8649353 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch
Attachment #8649317 - Attachment is obsolete: true
(Assignee)

Comment 23

2 years ago
(In reply to :aceman from comment #21)
> I am on Linux and the file is called .hgrc (also with the dot), and it is in
> my user home folder. Not in the Thunderbird source tree.

I am starting to think if mercurial.ini under C:/Users is the .hgrc on windows because that is what the setup writes to every time and this file does contain my user.name

Comment 24

2 years ago
I am almost sure that an .hgrc can be used for any repository just by creating it on the repository root. It can also be created on the user home directory to use allways that setup..

To do a quickfix, Aadithya, you could just edit directly the patch file. It shoiuld be located in [comm-central repo root dir]/.hg/patches

There you should edit the file where you have saved the patch, which I cannot guess. Add line:

# User (your name) <your address>

To update the commit message, for your next commit -as this one is ok- you could use:

hg qrefresh --message="<your commit message>"

If the commit message includes the " character, then it shoud be --message='message "some text"'
(Assignee)

Comment 25

2 years ago
Created attachment 8649360 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

Edited the patch as a quick fix to include my username
Attachment #8649360 - Flags: review?(acelists)
(Assignee)

Comment 26

2 years ago
(In reply to Javi Rueda from comment #24)
> I am almost sure that an .hgrc can be used for any repository just by
> creating it on the repository root. It can also be created on the user home
> directory to use allways that setup..
> 
> To do a quickfix, Aadithya, you could just edit directly the patch file. It
> shoiuld be located in [comm-central repo root dir]/.hg/patches
> 
> There you should edit the file where you have saved the patch, which I
> cannot guess. Add line:
> 
> # User (your name) <your address>
> 
> To update the commit message, for your next commit -as this one is ok- you
> could use:
> 
> hg qrefresh --message="<your commit message>"
> 
> If the commit message includes the " character, then it should be
> --message='message "some text"'

I edited the patch as a quick fix. I will try to find a  solution for the same.

Comment 27

2 years ago
Comment on attachment 8649360 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

Review of attachment 8649360 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, this works for me.

I think we do not need to change the strings IDs in this case as we do not need localizers to update their translations. They hopefully already have proper word for "antivirus" in their language versions.
Attachment #8649360 - Flags: review?(iann_bugzilla)
Attachment #8649360 - Flags: review?(acelists)
Attachment #8649360 - Flags: review+

Updated

2 years ago
Attachment #8649353 - Attachment is obsolete: true
(Assignee)

Comment 28

2 years ago
(In reply to :aceman from comment #27)
> Comment on attachment 8649360 [details] [diff] [review]
> Bug1189365_TypoFix_V2.patch
> 
> Review of attachment 8649360 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks, this works for me.
> 
> I think we do not need to change the strings IDs in this case as we do not
> need localizers to update their translations. They hopefully already have
> proper word for "antivirus" in their language versions.

Oh! Okay. So, Is the patch finalized > and do I have to do anything as part of next step?

Comment 29

2 years ago
Comment on attachment 8649360 [details] [diff] [review]
Bug1189365_TypoFix_V2.patch

r=me
Attachment #8649360 - Flags: review?(iann_bugzilla) → review+

Comment 30

2 years ago
The patch is done for now, let's wait for review of the Seamonkey part.

Comment 31

2 years ago
Thanks Ian, you may want to do this also in en-GB.

So it seems all is done here, let's check it in.
Aadithya, congrats to your first patch :)
Keywords: checkin-needed
(Assignee)

Comment 32

2 years ago
(In reply to :aceman from comment #31)
> Thanks Ian, you may want to do this also in en-GB.
> 
> So it seems all is done here, let's check it in.
> Aadithya, congrats to your first patch :)

Woah! :D Thanks :)

Comment 33

2 years ago
https://hg.mozilla.org/comm-central/rev/929b56b8c1ad97e816bd15e058bb068607648773
Bug 1189365 - "Anti-virus" typo fix in in security.dtd, mailnews_preferences.xhtml and pref-junk.dtd. r=aceman,iann a=aleth SM CLOSED TREE

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0

Comment 34

2 years ago
Verified in official nightly of 2015-09-06 that Daily users can update to.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.