Closed Bug 1189433 Opened 7 years ago Closed 7 years ago

[Aries] Contents of the SD card should be deleted before initiating a Gaia UI test run

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1182086

People

(Reporter: martijn.martijn, Unassigned)

References

Details

From bug 1187056, comment 15:
"
Yes, but the environment on the device is not specified in enough detail. It loads pictures off the SD card and in my case I have around 80-100 pictures that I took yesterday while trying to reproduce this bug. It seems to me that the test is not expecting that, which is why it's timing out for me. I don't know what set of pictures the test is expecting, and it doesn't appear to be documented anywhere.
"

Actually, when running a Gaia UI test, the contents of the SD card should be deleted according to the documentation:
http://gaiatest.readthedocs.org/en/latest/testrunner.html#risks
"
The gaiatest runner restores the target Firefox OS instance to a ‘clean’ state before every test. This means that any personal data such as contacts, SMS/MMS messages, emails, photos, videos, music, etc. will be removed. This will include data on the microSD card.
"

This was supposedly done in bug 1044019.

So if this is not doing that, deleting the contents of the SD card, that's a bug.
Note that on Flame the SD card did get wiped as expected. It was on Aries that it didn't. I'm just guessing but perhaps on Aries the SD card is mounted on a different mount point on the file system and the test runner doesn't account for that. I've run into similar issues in the past.
Ah, ok, so this happens on Aries. Currently, we don't really support that yet, but we're working on it, see bug 1181535.
Blocks: 1181535
Summary: Contents of the SD card should be deleted before initiating a Gaia UI test run → [Aries] Contents of the SD card should be deleted before initiating a Gaia UI test run
(not working on it, atm, though).
Assignee: martijn.martijn → nobody
Martijn made a patch that should fix this issue in bug 1182086.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1182086
You need to log in before you can comment on or make changes to this bug.