[OMTC] Inspector breadcrumbs labels are white instead of black (always reproducible)

RESOLVED DUPLICATE of bug 1185349

Status

RESOLVED DUPLICATE of bug 1185349
3 years ago
4 months ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox42 affected)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
STR (tested on Win7, Nightly 42.0a1 (2015-07-29), fresh profile):
1. Set white devtools theme.
2. Open page data:text/html,<body><script>var str='<div>';for(i=0;i<70;i++) str='<span>'+str;document.body.innerHTML=str;</script>
(or attached page)
3. Open devtools->Inspector (Ctrl+Shift+I)
4. Hide sidebar
5. Type "div" (without quotes) in field "Search with CSS selector"

RESULT:
Breadcrumbs were scrolled to the <div> label, but all visible <span> labels are white instead of black. (video in URL field)

EXPECTATIONS:
<span> labels should be black

NOTE:
There are also more STRs like this; some of them don't result in all visible labels having white color but rather 1-2 labels having white color instead of black
(Reporter)

Comment 1

3 years ago
Created attachment 8641189 [details]
testpage - Inspector breadcrumbs labels are white instead of black (always reproducible).html
(Reporter)

Updated

3 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Thank you for the video and STR.

I can't reproduce this on OS X or in a 32-bit Windows 7 VM.

Can you please verify that you still see this on your end?

Спасибо большое!
(Reporter)

Comment 3

3 years ago
(In reply to Dan Callahan [:callahad] from comment #2)
> Can you please verify that you still see this on your end?
Yes, it's still reproducible. After text labels become white, then in ~5 seconds they become black again
I figured out 3 things:
A) I can trigger similar issue in ESR 38, but rectangles with text lagels become dark (not black)
B) If I stop JavaScript in Debugger (in Browser Toolbox) after text labels become white, and then wait ~5 seconds, they still become black. That means that it's not JS that caused this issue
C) If I disable hardware acceleration then I don't see this issue.

So, I have a question:
Are graphical issues of this kind never fixed? (because "user must update graphics drivers")
(Reporter)

Updated

3 years ago
Summary: Inspector breadcrumbs labels are white instead of black (always reproducible) → [HWA] Inspector breadcrumbs labels are white instead of black (always reproducible)
Thank you for the updated STRs / video.

I'm still on the road, and it's super hard to reproduce this in a VM, even with hardware acceleration turned on.

I'll have access to a real Windows box in a week, and should be able to further dig in then.

> Are graphical issues of this kind never fixed? (because "user must update graphics drivers")

Not never, but glitches like that do tend to take longer to fix. :(
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

3 years ago
Created attachment 8654690 [details]
bug 1189438 - about-support Troubleshooting Information.xht

Here's my about:support page. Request additional info if needed.
I may be unavailable for very long time though. In this case, this bug should be closed.

Comment 7

3 years ago
(In reply to Dan Callahan [:callahad] from comment #2)
> Thank you for the video and STR.
> 
> I can't reproduce this on OS X or in a 32-bit Windows 7 VM.
> 
> Can you please verify that you still see this on your end?
> 
> Спасибо большое!

I can reproduce this bug as follows.

1) Open any pages (e.g. bugzilla.mozilla.org)
2) Select any elements in such a way as to [>]button(.scrollbutton-down) is displayed. (e.g. Narrow window width, Having a lot of child elements)
3) If .scrollbutton-down was changed disabled in the selection timing, breadcrumbs label font color turns white for 5 seconds.

Is this behavior designed? If so, it's a strange design specification.

Comment 8

3 years ago
Created attachment 8654691 [details]
inspector-screen-movie.mp4
(Reporter)

Comment 9

3 years ago
magicp, yes I knew about these steps but decided that they are unreliable...
(1) It should be "fixed" for you if you uncheck "Use hardware acceleration when available" on page about:preferences#advanced -> "General" tab
(2) Please open menu (≡)->(?)->"Trougleshooting information", save that whole page (or at least "Graphics" section) and upload here. That would be helpful

Comment 10

3 years ago
(In reply to arni2033 from comment #9)
> magicp, yes I knew about these steps but decided that they are unreliable...
> (1) It should be "fixed" for you if you uncheck "Use hardware acceleration
> when available" on page about:preferences#advanced -> "General" tab
Yes, it is.

> (2) Please open menu (≡)->(?)->"Trougleshooting information", save that
> whole page (or at least "Graphics" section) and upload here. That would be
> helpful
Please find attached file.

Comment 11

3 years ago
Created attachment 8655275 [details]
Troubleshooting Information-magicp.xht

Comment 12

3 years ago
(In reply to arni2033 from comment #9)
> magicp, yes I knew about these steps but decided that they are unreliable...
> (1) It should be "fixed" for you if you uncheck "Use hardware acceleration
> when available" on page about:preferences#advanced -> "General" tab
> (2) Please open menu (≡)->(?)->"Trougleshooting information", save that
> whole page (or at least "Graphics" section) and upload here. That would be
> helpful

Is this issue caused by OMTC (OffMainThreadCompositing)?
Could you try as follows

[about:preferences#advanced]
"Use hardware acceleration when available" = true
[about:config]
layers.offmainthreadcomposition.enabled = false

Probably, Window 7 VM and Mac OSX blocks(not use) OMTC
(Reporter)

Comment 13

3 years ago
@magicp:
Yes, you are right! With HWA on and OMTC off this does not happen! (is OMTC a part of HWA?)
// I actually tried disabling OMTC without browser restart (before reporting this), because OMTC haven't required it some month ago. And haven't got positive results. So restart is *necessary*
> Probably, Window 7 VM and Mac OSX blocks(not use) OMTC
This is very true. Markus Stange said in bug 1202714 that he can't repro it on Mac OS.
Summary: [HWA] Inspector breadcrumbs labels are white instead of black (always reproducible) → [OMTC] Inspector breadcrumbs labels are white instead of black (always reproducible)
(Reporter)

Updated

3 years ago
See Also: → bug 1212409
(Reporter)

Comment 14

3 years ago
Pushlog_url:   https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4d6d69f0f499dfc5c67df291858feda7bd2b9eac&tochange=d0fc7202b4cbe1ac8de823ed9e1e6dad706fc4d0
Not connected to 1212409.

@magicp: please next time add bug number to "See also" list so that nobody lost time
         searching for regression windows :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
See Also: bug 1212409
Duplicate of bug: 1185349
(Reporter)

Updated

3 years ago
Has STR: --- → yes

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.