Closed Bug 1189536 Opened 4 years ago Closed 4 years ago

Make service-workers/service-worker/fetch-request-xhr.https.html pass

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox42 --- affected
firefox44 --- fixed

People

(Reporter: jdm, Assigned: ehsan)

References

Details

Attachments

(2 files)

Dumping ground for my various test changes required to get it running in Firefox.
Depends on: 1189534
Assignee: nobody → josh
Status: NEW → ASSIGNED
Harness status: Timeout
Found 1 tests
1 Timeout
* Verify the body of FetchEvent using XMLHttpRequest -> timed out

Traces: https://pastebin.mozilla.org/8841201

since the test status is "Timeout" blocking the meta gathering this (Bug 1180622)
Blocks: 1180622
No longer blocks: 1189023
FWIW the timeout is caused by the use of HTTP_ORIGIN in the postMessage call, as well as various other places the the test's iframe. Once those are changed an actual failure is reported, but the test is designed so that either everything passes or the whole test fails. It's quite frustrating.
Also, I'm not sure its worth grouping stuff under a "timeout" meta bug.  We're fixing them regardless of the error type.
(In reply to Ben Kelly [:bkelly] from comment #4)
> Also, I'm not sure its worth grouping stuff under a "timeout" meta bug. 
> We're fixing them regardless of the error type.

ok, please feel free to remove all the meta bugs created to gather the different scenarios ("timeout"("file not found"), "error", "ok+failing tests"), and just use Bug 1189023 as the meta bug, in case they don't add any value to track wpt test suite issues.
Assignee: josh → ehsan
Attachment #8675896 - Flags: review?(bkelly)
Attachment #8675896 - Flags: review?(bkelly) → review+
Backed out for bustages like this:

 23:50:36     INFO - TEST-UNEXPECTED-TIMEOUT | /_mozilla/service-workers/service-worker/fetch-request-xhr.https.html | Verify the body of FetchEvent using XMLHttpRequest - Test timed out
 23:50:36     INFO - TEST-UNEXPECTED-TIMEOUT | /_mozilla/service-workers/service-worker/fetch-request-xhr.https.html | expected OK


https://treeherder.mozilla.org/logviewer.html#?job_id=15924928&repo=mozilla-inbound
https://hg.mozilla.org/mozilla-central/rev/3aaf22bdba2c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.