Closed Bug 1189582 Opened 6 years ago Closed 6 years ago

Make service-workers/service-worker/fetch-response-xhr.https.html pass

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox42 --- affected
firefox43 --- fixed

People

(Reporter: jdm, Assigned: jdm)

References

Details

Attachments

(1 file)

Dumping ground for changes needed to make this test pass.
Assignee: nobody → josh
Status: NEW → ASSIGNED
Harness status: Timeout

Found 1 tests
1 Timeout
* Verify the response of FetchEvent using XMLHttpRequest -> timed out

Traces: https://pastebin.mozilla.org/8841204

since the test status is "Timeout" blocking the meta gathering this (Bug 1180622)
Blocks: 1180622
No longer blocks: 1189023
The timeout is caused by the use of HTTP_ORIGIN instead of HTTPS_ORIGIN in the postMessage call.
Based on patches for Bug 1176988 the current patch for this test makes the test pass. Josh, is there anything else you had in mind considering this is marked WIP?
Nope!
url:        https://hg.mozilla.org/integration/mozilla-inbound/rev/73aa4c4fc3be34ae9cd4787540363be0664d6354
changeset:  73aa4c4fc3be34ae9cd4787540363be0664d6354
user:       Josh Matthews <josh@joshmatthews.net>
date:       Thu Jul 30 21:27:34 2015 -0400
description:
Bug 1189582 - Fix test-response-xhr.https.html and expectation data. r=nsm
https://hg.mozilla.org/mozilla-central/rev/73aa4c4fc3be
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Hi,

just checked on m-c (87e23922be37 revision) and the tests successfully run. Thanks for fixing it!.


Summary

Harness status: OK

Found 1 tests
1 Pass
Details
Result	Test Name
Pass	Verify the response of FetchEvent using XMLHttpRequest
You need to log in before you can comment on or make changes to this bug.