Closed Bug 1189628 Opened 4 years ago Closed 4 years ago

bad collapsing leads to huge JS run-to-completions being hidden in waterfall

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1197646

People

(Reporter: fitzgen, Unassigned)

Details

Attachments

(5 files)

A JS marker is being made a child of something that is shorter than it (!?) and comes after it (!??) and it results in giant empty space and confusion.

Attaching screenshots...
Attached image collapsed
Attached image expanded
This seems to happen pretty regularly to me.

STR:

* Open browser toolbox
* Go to imgur.com
* Open page toolbox, debugger panel
* Start recording in browser toolbox
* Refresh imgur.com
* Wait for ~10 seconds or so till imgur + debugger calm down
* Stop recording
Here is a profile exhibiting bad nesting/collapsing.
This looks like the same as bug 1197646 -- which also added a test ensuring that markers are all in order now
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1197646
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.