Feature Request: Change position of help button in Preferences

RESOLVED DUPLICATE of bug 1104075

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 1104075
2 years ago
2 years ago

People

(Reporter: beingalink, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8641560 [details]
prefs_no_help_to_see.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150730030208

Steps to reproduce:

-


Actual results:

-


Expected results:

The help button in the preferences is badly placed. As you can see from attached screenshot (prefs_no_help_to_see.png), it isn't visible on some pages at first sight since it's hidden at the bottom. This screenshot was taken on my 13" macbook with a fully maximized window. Also, as it is now, the button looks really lost at the bottom and it's really not a visually pleasing composition.

My suggestion is to put the button at the top on the right side of the line (see change_position_of_help.png). It's instantly visible and the page composition would be much nicer imho.
(Reporter)

Comment 1

2 years ago
Created attachment 8641561 [details]
change_position_of_help.png
(Reporter)

Updated

2 years ago
Component: Untriaged → Preferences
OS: Unspecified → All
Hardware: Unspecified → All

Comment 2

2 years ago
Just noticed this issue myself - the little help button looks lost. I'd agree with beingalink's suggestion.

Comment 3

2 years ago
Created attachment 8649309 [details]
change help position example

How does this look for a new position?

Moved the button to the header and added a spacer.

Comment 4

2 years ago
@jasonmoggridge - I think that looks a lot better in terms of placement.

Not sure about the colour though - either the question mark should be darker, or the icon background.

Is it meant to be the same colour as the little orange border to the left of the 'Content' menu item? If it is, then visually it doesn't quite seem so anyway.
(Reporter)

Comment 5

2 years ago
Position is much better like this imho. The question mark looks more black in my firefox on OS X and I think that would be better since, as already said, the contrast is too low in the draft picture.

Comment 6

2 years ago
I'm not very good at colors. What about having the background the color of the little orange border and the question mark the color of the background on the left side menu?

I do agree that at the least the question mark should be darker. I'll see what i can do.

Comment 7

2 years ago
Changing the background of the icon is easy enough, however i'm stuck on the color of the question mark. The question mark is a .svg image, but the image is black. So the color is somehow changing when it gets displayed, i'm really not sure where that's happening or why/how it's possible.

Comment 8

2 years ago
I am not at a computer, but if you right click and 'view element' you'll see the CSS style. Look for that style in the source.

Comment 9

2 years ago
Home now - looks like a list-style-image: http://stackoverflow.com/questions/5306640/setting-bullet-colors-in-ul-li-lists-via-css-without-using-images-or-span-tags

Comment 10

2 years ago
Created attachment 8649537 [details]
Screenshot of help screen markup showing help button

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104075
You need to log in before you can comment on or make changes to this bug.