tb 38.1.0 D3D11 related crash in driver for Nvidia Geforce 740M on startup when HWA, layers.acceleration and gfx.direct2d, are enabled

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
3 years ago
6 months ago

People

(Reporter: marnick.leau, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

38 Branch
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [startupcrash], crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Settings layers.acceleration.disabled and gfx.direct2d.disabled to true fixes the crash but is hardly an acceptable solution. I've been getting this crash for weeks every time I thought I'd try the 38 series until I got a hunch about hw accel being the culprit.

Windows 8.1 64bit, Nvidia Geforce 740M with driver 353.62, Intel HD Graphics 4000

--

Update to 38.1.0
start tb


Actual results:

Instant crash (uploaded a million crash reports, bp-ee9e8976-2f3a-483b-b715-9db092150728 is one of the crashIDs)


Expected results:

TB should have opened

Comment 1

3 years ago
So YOU are the one who created that million crash reports!  :)

There's some chance this might be bug 1187764. If so, you will find that 40.0 beta downloadable from https://www.mozilla.org/en-US/thunderbird/channel/ will work.  Could you try it for us?

If it fails, please post additional crash IDs.
If it works, please let us know.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ nvwgf2um.dll@0xf73ab ]
Component: Untriaged → General
Ever confirmed: true
Flags: needinfo?(marnick.leau)
Keywords: crash
Summary: tb 38.1.0 crashes on startup when layers.acceleration and gfx.direct2d are enabled → tb 38.1.0 D3D11 related crash in NVIDIA driver on startup when HWA, layers.acceleration and gfx.direct2d, are enabled

Comment 2

3 years ago
 nvwgf2um.dll@0xf73ab 
bp-ee9e8976-2f3a-483b-b715-9db092150728
Ø 0 	nvwgf2um.dll	nvwgf2um.dll@0xf73ab	
Ø 1 	nvwgf2um.dll	nvwgf2um.dll@0xf9bce	
Ø 2 	nvwgf2um.dll	nvwgf2um.dll@0xa51c9	
Ø 3 	nvumdshim.dll	nvumdshim.dll@0x2273e	
Ø 4 	nvumdshim.dll	nvumdshim.dll@0x30b63	
Ø 5 	nvumdshim.dll	nvumdshim.dll@0x1b9e8	
6 	d3d11.dll	d3d11.dll@0xcd6a9	
7 	d3d11.dll	CContext::ID3D11DeviceContext2_CopySubresourceRegion_<1>(ID3D11DeviceContext2*, ID3D11Resource*, unsigned int, unsigned int, unsigned int, unsigned int, ID3D11Resource*, unsigned int, D3D11_BOX const*)	
8 	d3d11.dll	NDXGI::CDevice::Blt(IDXGIResource*, tagRECT const*, tagRECT const*, unsigned int, IDXGIResource*, tagRECT const*, SUBRESOURCE_BLT_MAP const*, unsigned __int64, unsigned int, unsigned int)	
Ø 9 	dxgi.dll	dxgi.dll@0x40a93	
Ø 10 	dxgi.dll	dxgi.dll@0x1d67b	
Ø 11 	dxgi.dll	dxgi.dll@0x10bad	
Ø 12 	dxgi.dll	dxgi.dll@0x4271b	
13 	xul.dll	mozilla::layers::CompositorD3D11::EndFrame()	gfx/layers/d3d11/CompositorD3D11.cpp
14 	xul.dll	mozilla::layers::LayerManagerComposite::Render()	gfx/layers/composite/LayerManagerComposite.cpp
15 	xul.dll	mozilla::layers::LayerManagerComposite::EndTransaction(void (*)(mozilla::layers::PaintedLayer*, gfxContext*, nsIntRegion const&, mozilla::layers::DrawRegionClip, nsIntRegion const&, void*), void*, mozilla::layers::LayerManager::EndTransactionFlags)	gfx/layers/composite/LayerManagerComposite.cpp
Whiteboard: [startupcrash]
(Reporter)

Comment 3

3 years ago
40.0b1 also crashes with the hw accel options enabled; it doesn't fix the problem.
Flags: needinfo?(marnick.leau)

Comment 4

3 years ago
Need crash IDs please.
Flags: needinfo?(marnick.leau)
(Reporter)

Comment 5

3 years ago
Right, my bad, sorry.

It seems gfx.direct2d isn't related actually btw. Only layers.acceleration causes the crash.

bp-311f6874-ff26-4735-8966-50f122150731
Flags: needinfo?(marnick.leau)

Comment 6

3 years ago
https://downloadcenter.intel.com/download/24973/Intel-HD-Graphics-Driver-for-Windows-7-8-8-1-64-bit

Can you update to the latest Intel 10.18.10.4226 driver for HD4000 and see if it still crashes?
(Reporter)

Comment 7

3 years ago
(In reply to GMA from comment #6)
> https://downloadcenter.intel.com/download/24973/Intel-HD-Graphics-Driver-for-
> Windows-7-8-8-1-64-bit
> 
> Can you update to the latest Intel 10.18.10.4226 driver for HD4000 and see
> if it still crashes?

No change

Comment 8

3 years ago
I am going to guess that line 1131 is the culprit:

  1118      nsIntRegionRectIterator iter(mInvalidRegion);
  1119      const IntRect* r;
  1120      uint32_t i = 0;
  1121      while ((r = iter.Next()) != nullptr) {
  1122        RECT rect;
  1123        rect.left = r->x;
  ...
  1128        rects.push_back(rect);
  1129      }
  1130
  1131      params.pDirtyRects = &rects.front();
  1132      chain->Present1(presentInterval, mDisableSequenceForNextFrame ? DXGI_PRESENT_DO_NOT_SEQUENCE : 0, &params);

because it assumes that rects is nonempty.

Comment 9

3 years ago
(In reply to q1 from comment #8)
> I am going to guess that line 1131 is the culprit:

That would be in CompositorD3D11.cpp, function EndFrame.
(Reporter)

Comment 11

3 years ago
(In reply to NVD from comment #10)
> http://www.geforce.com/whats-new/articles/geforce-355-60-whql-driver-released
> 
> Please test GeForce 355.60 WHQL driver.

No change
marnick, 
Do you still crash in version 45 with HWA enabled?
If you do, is it  better with (in this order)
1. current beta version from http://www.mozilla.org/en-US/thunderbird/channel/ ?
2. latest NVIDIA driver (As of Dec 16, 2016 driver version is up to 376.33) ?
Blocks: 1195947
Flags: needinfo?(marnick.leau)
Summary: tb 38.1.0 D3D11 related crash in NVIDIA driver on startup when HWA, layers.acceleration and gfx.direct2d, are enabled → tb 38.1.0 D3D11 related crash in driver for Nvidia Geforce 740M on startup when HWA, layers.acceleration and gfx.direct2d, are enabled
(Reporter)

Comment 14

6 months ago
I confirm I can set both preferences to true today and nothing bad happens. Problem seems to be gone.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(marnick.leau)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.