HTTP Accepts: should include MNG mimetype

RESOLVED FIXED

Status

()

Core
Networking: HTTP
--
enhancement
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Peter Janes, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Now that it's a supported format in the browser, Mozilla's HTTP "Accepts" header
should include video/x-mng, the MNG mimetype.
(Assignee)

Comment 1

16 years ago
patch welcome :-)

Comment 2

16 years ago
I think bug 118838 is a dupe of this.
(Assignee)

Comment 3

16 years ago
gerv?
Yes, it should. This is the one additional type we planned to add. No q value
(i.e. q=1.0). As Darin says, this is a trivial patch, which anyone can do :-)

Put it before image/png. While you are there, move text/plain after text/html
(for consistency), and remove all the spaces, as I'm pretty sure (unless Darin
wants to correct me) that they are not necessary. That'll shorten it a bit.

Gerv
(Reporter)

Comment 5

16 years ago
norton@w5ac.tamu.edu is right about the dup, btw.  (Technically it's a dup of
this one--bug 118838 is a symptom and this is the cause. :)  When I add
"video/x-mng" to user_pref("network.http.accept.default"), content negotiation
works and the file is displayed.
(Reporter)

Comment 6

16 years ago
Created attachment 64170 [details] [diff] [review]
Trivial patch for HTTP Accepts

As Gervase says, anyone can handle this patch.	(Even me! :)

video/x-mng is added before image/png.	Also, per comments in the bug,
whitespace is removed and the position of text/plain is shifted.
(Assignee)

Comment 7

16 years ago
Comment on attachment 64170 [details] [diff] [review]
Trivial patch for HTTP Accepts

sr=darin
Attachment #64170 - Flags: superreview+
Blocks: 118838
Comment on attachment 64170 [details] [diff] [review]
Trivial patch for HTTP Accepts

r=bzbarsky

Peter, want me to check this in?
Attachment #64170 - Flags: review+
(Reporter)

Comment 9

16 years ago
Sure, please do.

Comment 10

16 years ago
*** Bug 118838 has been marked as a duplicate of this bug. ***
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 12

16 years ago
Wasn't there discussion at some point to make the accept headers as small as
possible (ie, "*/*")?

If you're going to add all the image types, there's JNG, BMP, and ICO missing.

(Assignee)

Comment 13

16 years ago
at one time, the accept header was */*, but it was decided to add a simple set
of static values to enable some limited degree of content negotiation.  the
current accept header is meant to reflect that.  moreover, we plan to have a
different accept header for requests that are known to result in images to help
reduce the size of the accept header.
Yes. I think sites will legitimately want to serve MNG if the browser supports
it, and animated GIF if not. 

Gerv
You need to log in before you can comment on or make changes to this bug.