Closed Bug 1189791 Opened 7 years ago Closed 7 years ago

Intermittent FileAPI/blob/Blob-slice.html | application crashed [@ mozilla::dom::MessagePort::Entangled(nsTArray<mozilla::dom::MessagePortMessage> &)]

Categories

(Core :: DOM: Core & HTML, defect)

Other Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1181595

People

(Reporter: RyanVM, Unassigned)

Details

(Keywords: crash, intermittent-failure)

18:14:07 INFO - TEST-START | /FileAPI/blob/Blob-slice.html
18:14:10 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/D7lvauROTWCWYmZUtp_2AQ/artifacts/public/build/firefox-42.0a1.en-US.win32.crashreporter-symbols.zip
18:14:21 INFO - mozcrash Saved minidump as C:\slave\test\build\blobber_upload_dir\5b217156-d2b2-43a9-86ba-b43e3a7908ca.dmp
18:14:21 INFO - mozcrash Saved app info as C:\slave\test\build\blobber_upload_dir\5b217156-d2b2-43a9-86ba-b43e3a7908ca.extra
18:14:21 INFO - PROCESS-CRASH | /FileAPI/blob/Blob-slice.html | application crashed [@ mozilla::dom::MessagePort::Entangled(nsTArray<mozilla::dom::MessagePortMessage> &)]
18:14:21 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpwpfrg2.mozrunner\minidumps\5b217156-d2b2-43a9-86ba-b43e3a7908ca.dmp
18:14:21 INFO - Operating system: Windows NT
18:14:21 INFO - 6.1.7601 Service Pack 1
18:14:21 INFO - CPU: x86
18:14:21 INFO - GenuineIntel family 6 model 30 stepping 5
18:14:21 INFO - 8 CPUs
18:14:21 INFO -
18:14:21 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_WRITE
18:14:21 INFO - Crash address: 0x50
18:14:21 INFO -
18:14:21 INFO - Thread 0 (crashed)
18:14:21 INFO - 0 xul.dll!mozilla::dom::MessagePort::Entangled(nsTArray<mozilla::dom::MessagePortMessage> &) [MessagePort.cpp:6a16c1845238 : 593 + 0x0]
18:14:21 INFO - eip = 0x67205d58 esp = 0x001eef0c ebp = 0x001eef20 ebx = 0x001ef0a8
18:14:21 INFO - esi = 0x00000000 edi = 0x00000040 eax = 0x67c12dc4 ecx = 0x00000000
18:14:21 INFO - edx = 0x238221d8 efl = 0x00210216
18:14:21 INFO - Found by: given as instruction pointer in context
18:14:21 INFO - 1 xul.dll!mozilla::dom::MessagePortChild::RecvEntangled(nsTArray<mozilla::dom::MessagePortMessage> &&) [MessagePortChild.cpp:6a16c1845238 : 27 + 0xa]
18:14:21 INFO - eip = 0x67206ea9 esp = 0x001eef28 ebp = 0x001eef2c
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 2 xul.dll!mozilla::dom::PMessagePortChild::OnMessageReceived(IPC::Message const &) [PMessagePortChild.cpp:6a16c1845238 : 240 + 0xc]
18:14:21 INFO - eip = 0x668e27d9 esp = 0x001eef34 ebp = 0x001eef54
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 3 xul.dll!mozilla::ipc::PBackgroundChild::OnMessageReceived(IPC::Message const &) [PBackgroundChild.cpp:6a16c1845238 : 1236 + 0x5]
18:14:21 INFO - eip = 0x65f468ad esp = 0x001eef5c ebp = 0x001eefec
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 4 xul.dll!mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const &) [MessageChannel.cpp:6a16c1845238 : 1382 + 0xa]
18:14:21 INFO - eip = 0x66349870 esp = 0x001eeff4 ebp = 0x001ef004
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 5 xul.dll!mozilla::ipc::MessageChannel::DispatchMessageW(IPC::Message const &) [MessageChannel.cpp:6a16c1845238 : 1302 + 0x7]
18:14:21 INFO - eip = 0x6634954e esp = 0x001ef00c ebp = 0x001ef08c
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 6 xul.dll!mozilla::ipc::MessageChannel::OnMaybeDequeueOne() [MessageChannel.cpp:6a16c1845238 : 1273 + 0xb]
18:14:21 INFO - eip = 0x66349398 esp = 0x001ef094 ebp = 0x001ef0c0
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 7 xul.dll!MessageLoop::DoWork() [message_loop.cc:6a16c1845238 : 459 + 0x19]
18:14:21 INFO - eip = 0x6603f167 esp = 0x001ef0c8 ebp = 0x001ef124
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 8 xul.dll!mozilla::ipc::DoWorkRunnable::Run() [MessagePump.cpp:6a16c1845238 : 220 + 0x6]
18:14:21 INFO - eip = 0x6602d5c7 esp = 0x001ef12c ebp = 0x001ef134
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 9 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:6a16c1845238 : 867 + 0x5]
18:14:21 INFO - eip = 0x6604175e esp = 0x001ef13c ebp = 0x001ef22c
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 10 xul.dll!mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate *) [MessagePump.cpp:6a16c1845238 : 95 + 0x16]
18:14:21 INFO - eip = 0x66040698 esp = 0x001ef234 ebp = 0x001ef260
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 11 xul.dll!MessageLoop::RunHandler() [message_loop.cc:6a16c1845238 : 227 + 0x7]
18:14:21 INFO - eip = 0x6603ece9 esp = 0x001ef268 ebp = 0x001ef298
18:14:21 INFO - Found by: call frame info
18:14:21 INFO - 12 xul.dll!MessageLoop::Run() [message_loop.cc:6a16c1845238 : 201 + 0x6]
18:14:21 INFO - eip = 0x6603ebb4 esp = 0x001ef2a0 ebp = 0x001ef2b8
18:14:21 INFO - Found by: call frame info
Flags: needinfo?(amarchesini)
Fixed by 1181595.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 1181595
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.