Firefox doesn't re-open after OSX restarts even if "Reopen Windows..." is checked in the system restart dialog

RESOLVED DUPLICATE of bug 639707

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 639707
3 years ago
3 years ago

People

(Reporter: adavis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [FXGrowth])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8641750 [details]
Mac OS X Restart Dialog

Firefox doesn't automatically re-open after restart even though "Reopen Windows when logging back in" is checked in the restart dialog. (see attached screenshot of Mac restart dialog)

When I restart, I rarely close all my applications. Upon restarting, my entire system resumes it's past state. All applications re-open, except for Firefox.

I've tested it with both these versions:
-Dev Edition 41.0a2
-Firefox 40.0 (beta)

This is particularly bad when you use multiple browsers because upon restart, Chrome re-opens (but not FX) and so I often find myself using Chrome accidentally since it's the first browser I see.

Updated

3 years ago
Summary: Firefox doesn't re-open after system restart even if "Reopen Windows..." is checked in the system restart dialog → Firefox doesn't re-open after OSX restarts even if "Reopen Windows..." is checked in the system restart dialog
(Reporter)

Updated

3 years ago
Whiteboard: [FXGrowth]
(Reporter)

Comment 1

3 years ago
MattN, do you know who we could escalate this to?

This should be a quick fix (from what I've heard) and would really help increase the stickiness of our product.
Flags: needinfo?(MattN+bmo)
Pretty sure this is bug 639707.

I don't know that this is actually a "quick fix", I can see it being complicated to figure out how our own session-restore and the native OS X mechanisms intermix.

It would be helpful is someone familiar with Cocoa could help out with investigating what need to be be done here... mstange?
Component: General → Session Restore
Flags: needinfo?(MattN+bmo) → needinfo?(mstange)
I also believe it's the same bug and I have an idea of what the problem is which I will mention in bug 639707 now.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mstange)
Resolution: --- → DUPLICATE
Duplicate of bug: 639707
You need to log in before you can comment on or make changes to this bug.