Change sync post-login page (about:accounts) to instead direct to account:preferences#sync

RESOLVED FIXED in Firefox 43

Status

()

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rfeeley, Assigned: eoger)

Tracking

39 Branch
Firefox 43
Points:
---
Bug Flags:
firefox-backlog +
in-testsuite +

Firefox Tracking Flags

(firefox43 fixed)

Details

(Whiteboard: [fxsync])

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
Flags: firefox-backlog?
(Reporter)

Comment 1

3 years ago
With in-content preferences launching in release, and account:preferences#sync getting a small makeover, it makes sense that the sync experiences link to account:preferences#sync instead of about:accounts.

After users log in to sync, we should open account:preferences#sync instead of about:accounts.

Updated

3 years ago
Flags: firefox-backlog? → firefox-backlog+
Priority: -- → P1
(Assignee)

Comment 2

3 years ago
Created attachment 8643311 [details] [diff] [review]
bug-1189842.patch

Ryan: Do you want us to close the about:accounts tab when we open the about:preferences#sync tab?

Mark: If Ryan answers yes to the above question, I might need directions on how to make the "Test the remote commands" test work in browser_aboutAccounts.js when we close the about:accounts window.
Assignee: nobody → eoger+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(rfeeley)
Attachment #8643311 - Flags: feedback?(markh)
Comment on attachment 8643311 [details] [diff] [review]
bug-1189842.patch

Review of attachment 8643311 [details] [diff] [review]:
-----------------------------------------------------------------

The code looks fine but I'm wondering if the user may get a little confused by the magic tabs switching that's going on. I think we should make a try build for rfeeley to sign off on the actual UX in-case it differs from his perceived UX.

::: browser/base/content/test/general/browser_aboutAccounts.js
@@ +38,5 @@
>  {
>    desc: "Test the remote commands",
>    teardown: function* () {
>      gBrowser.removeCurrentTab();
> +    gBrowser.removeCurrentTab();

we should add a comment here saying why we are nuking 2 tabs.
Attachment #8643311 - Flags: feedback?(markh) → feedback+
Iteration: --- → 43.1 - Aug 24

Updated

3 years ago
Whiteboard: [fxsync]
(Assignee)

Comment 4

3 years ago
> [11:54:11]  <rfeeley>	the build is great
> [11:54:16]  <rfeeley>	works as designed!

It was a build using patched from both bug 1189842 and bug 1152385.
Flags: needinfo?(rfeeley)
(Assignee)

Comment 5

3 years ago
Created attachment 8647255 [details] [diff] [review]
bug-1189842.patch

Updated and rebased.
Attachment #8643311 - Attachment is obsolete: true
Attachment #8647255 - Flags: review?(markh)
Attachment #8647255 - Flags: review?(markh) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/92cb84b00e00
Keywords: checkin-needed
Whiteboard: [fxsync] → [fxsync][fixed-in-fx-team]
And Windows
See Also: → bug 1194537
https://hg.mozilla.org/mozilla-central/rev/9a5f3dd7d1c0
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fxsync][fixed-in-fx-team] → [fxsync]
Target Milestone: --- → Firefox 43
(Reporter)

Comment 12

3 years ago
The "Account connected" screen has been deprecated. After successful sign-in, please transition the user to about:preferences#sync instead opening it in a new tab (poor language choice on my fault), and "Account connected". I'll be filing a bug with this and other improvements.
(In reply to Ryan Feeley [:rfeeley] from comment #12)
> The "Account connected" screen has been deprecated. After successful
> sign-in, please transition the user to about:preferences#sync instead
> opening it in a new tab (poor language choice on my fault), and "Account
> connected". I'll be filing a bug with this and other improvements.

Ryan, I'm not sure what you are asking for here. What happens now is:

* User is on about:preferences#sync and does signup.
* about:accounts is opened in a new tab - so we have 2 relevant tabs open.
* After signup completes we switch back to the existing about:preferences tab.
* about:accounts remains open as a "background" tab showing the "Account Connected" page.

So after the process we *are* back on about:preferences#sync, but about:accounts does remain open.  Are you asking for that new about:accounts tab to be automatically closed after the process completes?  Note we probably do not want to transition the about:accounts tab to about:preferences#sync, as that would leave the user with two about:preferences tabs open.

Either way, can you please open a new bug and CC me?
Flags: needinfo?(rfeeley)
(Reporter)

Updated

3 years ago
See Also: → bug 1199303
(Reporter)

Comment 14

3 years ago
In step two you say "about:accounts is opened in a new tab". I think this is no longer the case. Nothing should close. We just just try to make sure the user lands in the preferences (because it helps them understand what sync does and the UI is right there).
Flags: needinfo?(rfeeley) → needinfo?(markh)
(In reply to Ryan Feeley [:rfeeley] from comment #14)
> In step two you say "about:accounts is opened in a new tab". I think this is
> no longer the case. Nothing should close. We just just try to make sure the
> user lands in the preferences (because it helps them understand what sync
> does and the UI is right there).

Yep, that's (obviously) true, so I think we are all good.
Flags: needinfo?(markh)
You need to log in before you can comment on or make changes to this bug.