[Camera] No shutter sound is present.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: NicholasN, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8641936 [details]
logcat_camera_shutter.txt

Description:
The user has the volume up on all audio channels in settings, and then goes to camera and takes a picture. No shutter sound plays when the camera button is tapped.


Repro Steps:
1) Update a Aries to 20150731163020
2) Go to Settings > Sounds and ensure that audio channels are turned up.
3) Ensure the camera box is checked under Other Sounds.
4) Go to camera and take a photo.


Actual:
Shutter sound is not triggered when picture is taken.


Expected:
Shutter sound is triggered when picture is taken.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150731163020
Gaia: 8502d07cd7e68da79303471acf64eea48b3dce24
Gecko: ca53d4297f02
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 5/5
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
Issue occurs on Flame 2.5, but not on Flame 2.2

Flame 2.5

Actual Result:

Shutter sound is not triggered when picture is taken.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150731030207
Gaia: 8502d07cd7e68da79303471acf64eea48b3dce24
Gecko: ca53d4297f02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual Result:

Shutter sound triggers when picture is taken.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150731032507
Gaia: 8f3749f875c5ed155ccbd630aa2ee4e8bc2a9400
Gecko: f1aefb986403
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
Functional regression

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted

Updated

3 years ago
QA Contact: mshuman
This issue appears to be caused by:
Bug 1156472 - Allow of capture of audio in various forms of screen sharing (tab/window/etc).

Mozilla-Inbound Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150727071843
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: c22ad1335d55
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150727072546
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: 8541ce2730c0
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Last Working gaia / First Broken gecko - Issue DOES reproduce
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: 8541ce2730c0

First Broken gaia / Last Working gecko - Issue does NOT reproduce
Gaia: ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gecko: c22ad1335d55

Mozilla Inbound Pushlog: 
hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c22ad1335d55&tochange=8541ce2730c0
Blocks: 1156472
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Paul, can you take a look at this please. This might have been caused by the landing for bug 1156472.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(padenot)

Comment 5

3 years ago
regression, please fix.
blocking-b2g: 2.5? → 2.5+
It's unclear why that would be the case. That said, just before my patches, a lot of audio channel things got changed.
Flags: needinfo?(padenot)
I was able to reproduce using an older local build, but after updating my trees, it seems to have been fixed. It is also working on the latest aries build from taskcluster:

Build ID               20150813160011
Gaia Revision          acfaa3957e65d52a0af2185149628a520edcc7e2
Gaia Date              2015-08-13 12:34:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cdf53a4dee219aabec7462888875bac08b093edc
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150813.152410
Firmware Date          Thu Aug 13 15:24:17 UTC 2015
Bootloader             s1

A number of audio related patches have landed since the regression window, so I assume one of them has fixed it. Please reopen if the above build (or later) does not work for you.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.