If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Make Default Browser" prompt appears off screen

RESOLVED FIXED in mozilla0.9.8

Status

SeaMonkey
UI Design
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Ryan Farmer, Assigned: Bill Law)

Tracking

Trunk
mozilla0.9.8
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.7+) Gecko/20020109
BuildID:    20020109

When I started up todays Mozilla build, the "Make Default Browser" prompt,
appeared at the top left of my screen, running off screen in fact, leaving only
the option buttons visible.

Reproducible: Always
Steps to Reproduce:
1. Make another browser the defualt
2. Start Mozilla
3. When Mozilla starts, the "Make Default Browser" confirmation dialog box will
appear in the wrong place.
->bill
Assignee: trudelle → law
Keywords: qawanted

Comment 2

16 years ago
Confirmed.  Win2k.   2002010903
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Also, for me at least...    Even if I do click "Yes", I get the same dialog
every time I launch Mozilla.

Comment 4

16 years ago
Nominating for machv.
Keywords: nsbeta1

Comment 5

16 years ago
*** Bug 119026 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Something must have changed in nsIPrompt (or related code).

This may go away with the pending fix for bug 87257.
Target Milestone: --- → mozilla0.9.8
*** Bug 119089 has been marked as a duplicate of this bug. ***
Blocks: 119141
No longer blocks: 119141
*** Bug 119141 has been marked as a duplicate of this bug. ***
*** Bug 119208 has been marked as a duplicate of this bug. ***
looking at nsWindowsHooks.cpp, we use the common dialog. [ConfirmEx()]

maybe the centering bug lies there?  or a bug in some lower level window code.
*** Bug 119238 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
I recently changed the semantics of "centerscreen" for dependent windows: they
now interpret that as "center on parent." This dialog is given an incompletely
initialized parent window (the nascent initial browser window). It attempts to
center on it and ends up in a somewhat random position.

This could be fixed by removing the parent parameter sent by
checkForDefaultBrowser. But let me think about this one for a bit. Maybe I can
error-proof dependent window centering a little better.
(Assignee)

Comment 13

16 years ago
That's what I suspected.  So the fix I mention in comment 6 should take care of
this problem.  Or at least the symptom.  Maybe this needs fixing to prevent it
cropping up again, though.
(Assignee)

Updated

16 years ago
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

16 years ago
fixed along with 87257
*** Bug 119356 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
*** Bug 119379 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
*** Bug 119453 has been marked as a duplicate of this bug. ***
Keywords: qawanted
QA Contact: sairuh → tpreston
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.