Thunderbird hangs when trying to attach a file

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: David Davis, Unassigned)

Tracking

({hang})

31 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; .NET CLR 1.1.4322; GWX:QUALIFIED; rv:11.0) like Gecko

Steps to reproduce:

Tried to attach a photo to a email, bug hangs if its a photo or a PDF, any type of file!


Actual results:

Thunderbird hangs with "not responding". Then you have to close Thunderbird and start over! No crash report gets generated.


Expected results:

Open folders. and allow me to select a file!

Comment 1

3 years ago
If this is the same user from https://support.mozilla.org/en-US/questions/1069724 ...

"I used Thunderbird in Safe Mode and the same failure occurs! I don't share files [file shares] with another computer. Thunderbird worked fine for me before the 38.0 update."

This was done with both Windows and Thunderbird safe mode, correct?
Severity: normal → critical
Flags: needinfo?(wee_wood)
Keywords: hang
OS: Unspecified → Windows 7
(Reporter)

Comment 2

3 years ago
Yes, this is the same user! I was asked to open a bug report!
Flags: needinfo?(wee_wood)

Updated

3 years ago
(In reply to David Davis from comment #2)
> Yes, this is the same user! I was asked to open a bug report!

David, pls answer all questions if you want us to assist with what is most likely NOT a bug in TB, but some other problem particular to your setup.

(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #1)
> If this is the same user from
> https://support.mozilla.org/en-US/questions/1069724 ...
> 
> "I used Thunderbird in Safe Mode and the same failure occurs! [...]
>
> This was done with both Windows and Thunderbird safe mode, correct?

So Wayne wants to know this:
Does this "bug" still occur when you:
- start your Windows operating system in "Safe Mode" (while booting)
- AND start Thunderbird in "Safe Mode" (help > restart with addons disabled)?
Flags: needinfo?(wee_wood)
Also, there's another unanswered question from Wayne on the support ticket:

"Does it happen if you disable automatic safe at tools | options | composition | general ?"
So you need to remove the checkmark before [ ] "Auto Save every [xx] minutes" and then see if the bug still occurs.
(Reporter)

Comment 5

3 years ago
I started windows in safe mode, then started Thunderbird in safe mode, then selected Tools/Options/Composition/General and removed the check mark for Auto Save! When I attempted to attach a file to an email, Thunderbird hangs (not responding)and I have to use Windows Task Manager to clear the hang! If the problem is because of my setup, then why did it first occur when I upgraded Thunderbird to Version 38.0, and still fails at Version 38.1? Prior to Version 38.0, Thunderbird worked just fine, for years! Regards, David
Flags: needinfo?(wee_wood)

Comment 6

3 years ago
David,
Please update to version 38.2.0.
Is it better?
Flags: needinfo?(wee_wood)
(Reporter)

Comment 7

3 years ago
Installed Version 38.2, and have the same problem! Also, noticed that I can not open an email that has an attachment, it hangs the same way as adding one! Is there a way to completely remove Thunderbird and reinstall it? I suspect something bad in the registry! Regards, David
Flags: needinfo?(wee_wood)
(Reporter)

Comment 8

3 years ago
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #6)
> David,
> Please update to version 38.2.0.
> Is it better?

Installed Version 38.2, and have the same problem! Also, noticed that I can not open an email that has an attachment, it hangs the same way as adding one! Is there a way to completely remove Thunderbird and reinstall it? I suspect something bad in the registry! Regards, David

Comment 9

3 years ago
Thanks for updating. A registry entry would not cause this type of problem.

Comment 10

3 years ago
David, I agree with Wayne.  A registry entry is not very likely.  However File system error may be.

First run the disk cleanup tool in theSystem tools group on the start menu.  Then right click the C: drive in Windows explorer, select properties in in the Tools tab select check for errors.   This will only schedule the check and a full check will occur when windows is restarted and may take hours.  So do it when you will not be wanting the machine for some time.
(Reporter)

Comment 11

3 years ago
I ran the cleanup tool and then ran CHKDSK on the C: drive! There were no errors! I then tried Thunderbird again, but still have the same problem! Do you have anymore thoughts?

Comment 12

3 years ago
I suggest installing v31 from http://archive.mozilla.org/pub/mozilla.org/thunderbird/releases/31.8.0/win32/en-US/ and see where that gets you
(Reporter)

Comment 13

3 years ago
Installed V31, but still have the problem! I uninstalled Norton 360 and Stopzilla, then ran another test, still have the same problem! Just can't figure this one out!!!!

Updated

3 years ago
Version: 38 → 31
(Reporter)

Comment 14

3 years ago
Already installed V31!

Comment 15

3 years ago
I can only reproduce my bug on one of two Win8.1 computers.
that bug is 1195617
Since that occurs on autosave of drafts, my workaround for this has been to not attach files until right before sending.
Considered installing prior versions, but not felt the need yet.
Jim

Updated

3 years ago
See Also: → bug 1195617
(Reporter)

Comment 16

3 years ago
I've been testing Thunderbird with Windows 10 and it appears as though everything is working properly! So this bug can be closed!

Comment 17

3 years ago
(In reply to David Davis from comment #16)
> I've been testing Thunderbird with Windows 10 and it appears as though
> everything is working properly! So this bug can be closed!

So you no longer have the win8 machine?
Flags: needinfo?(wee_wood)

Comment 18

2 years ago
WFM per comment 16
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(wee_wood)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.