[Windows 10] Jumplist icon almost not visible

RESOLVED FIXED in Thunderbird 42.0

Status

Thunderbird
OS Integration
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Paenglab, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 42.0
All
Windows 10

Thunderbird Tracking Flags

(thunderbird40 affected, thunderbird41 fixed, thunderbird42 fixed, thunderbird_esr3840+ fixed)

Details

Attachments

(7 attachments, 4 obsolete attachments)

(Assignee)

Description

2 years ago
Created attachment 8642043 [details]
jumplist.png

Windows 10 uses now a black background for the jumplists. This makes the dark Win7 icons almost invisible.
(Assignee)

Comment 1

2 years ago
Created attachment 8642045 [details] [diff] [review]
jumplist.patch

I'm using now a separate image instead of mail-toolbar-aero.png. This gives us also the possibilty to remove this toolbar images as they are no longer needed with our svg images (I'll file a new bug to remove them).
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8642045 - Flags: review?(bwinton)
(Assignee)

Comment 2

2 years ago
Created attachment 8642046 [details]
Patch applied on Win 10
(Assignee)

Comment 3

2 years ago
Created attachment 8642047 [details]
Patch applied on Win 7
(Assignee)

Comment 4

2 years ago
Created attachment 8642063 [details] [diff] [review]
jumplist.patch

The address book icon had a little bit a too small body (but not as the Win 7 screenshot shows, this was a cached icon from a previous version). Now made the body better visible.
Attachment #8642045 - Attachment is obsolete: true
Attachment #8642045 - Flags: review?(bwinton)
Attachment #8642063 - Flags: review?(bwinton)
(Assignee)

Comment 5

2 years ago
Created attachment 8642064 [details]
Patch applied on Win 10
Attachment #8642046 - Attachment is obsolete: true
(Assignee)

Comment 6

2 years ago
Created attachment 8642065 [details]
Patch applied on Win 7

This is now showing the real icons. I had problems to show the correct icons as Windows cached the first version and didn't want to update to the latest.
Attachment #8642047 - Attachment is obsolete: true
Comment on attachment 8642063 [details] [diff] [review]
jumplist.patch

I don't have internet (except for about 30 minutes per day) for the next couple of weeks at least.  You should probably ask someone else for review…
Attachment #8642063 - Flags: review?(bwinton)
(Assignee)

Comment 8

2 years ago
Comment on attachment 8642063 [details] [diff] [review]
jumplist.patch

Jim, do you have time for a simple review? It's a simple change and the screenshots should be enough for the review.
Attachment #8642063 - Flags: review?(squibblyflabbetydoo)

Comment 9

2 years ago
Comment on attachment 8642063 [details] [diff] [review]
jumplist.patch

Review of attachment 8642063 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me. I think these icons look worse than the existing ones, but I suppose that's just because of the switch to SVG for all the toolbar icons...
Attachment #8642063 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 10

2 years ago
Created attachment 8642266 [details] [diff] [review]
jumplist.patch

Updated the reviewer in commit message.
Attachment #8642063 - Attachment is obsolete: true
Attachment #8642266 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Updated

2 years ago
tracking-thunderbird_esr38: --- → +
(Assignee)

Comment 11

2 years ago
Created attachment 8642545 [details]
jumplist.png for TB 38

If we want it for TB 38, we should use this image for the icons to fit the toolbar icons on TB 38.

If desired I can create a patch for ESR.

Comment 12

2 years ago
url:        https://hg.mozilla.org/comm-central/rev/b0a9ac1ed7f0ec7779022b36577f0eb3c1e5b9d1
changeset:  b0a9ac1ed7f0ec7779022b36577f0eb3c1e5b9d1
user:       Richard Marti <richard.marti@gmail.com>
date:       Sat Aug 01 18:36:19 2015 +0200
description:
Bug 1190080 - Update the Jumplist icons for Windows 10. r=squib

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 42.0
(Assignee)

Comment 13

2 years ago
Comment on attachment 8642266 [details] [diff] [review]
jumplist.patch

[Approval Request Comment]
Regression caused by: Windows 10 uses a dark background for the jumplist
User impact if declined: almost invisible icons
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, only changed icons
Attachment #8642266 - Flags: approval-comm-beta?
Attachment #8642266 - Flags: approval-comm-aurora?
(Assignee)

Comment 14

2 years ago
Created attachment 8644962 [details] [diff] [review]
jumplist-ESR.patch

Patch with icons for ESR.

[Approval Request Comment]
Regression caused by: Windows 10 uses a dark background for the jumplist
User impact if declined: almost invisible icons
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low, only changed icons
Attachment #8644962 - Flags: approval-comm-esr38?
(Assignee)

Comment 15

2 years ago
Created attachment 8644964 [details]
jumplists with ESR patch

Comment 16

2 years ago
Comment on attachment 8644962 [details] [diff] [review]
jumplist-ESR.patch

http://hg.mozilla.org/releases/comm-esr38/rev/0b02beb05d4c
Attachment #8644962 - Flags: approval-comm-esr38? → approval-comm-esr38+

Updated

2 years ago
status-thunderbird_esr38: --- → fixed
tracking-thunderbird_esr38: + → 40+

Comment 17

2 years ago
Comment on attachment 8642266 [details] [diff] [review]
jumplist.patch

https://hg.mozilla.org/releases/comm-beta/rev/0681e92bad2e
Attachment #8642266 - Flags: approval-comm-beta?
Attachment #8642266 - Flags: approval-comm-beta+
Attachment #8642266 - Flags: approval-comm-aurora?

Updated

2 years ago
status-thunderbird40: --- → affected
status-thunderbird41: --- → fixed
status-thunderbird42: --- → fixed
You need to log in before you can comment on or make changes to this bug.