Open Bug 1190163 Opened 4 years ago Updated 3 years ago

Tabs in Preferences -> Advanced -> 'View Certificates' are not themed correctly in gtk3 builds (42.0a1 nightly from source)

Categories

(Core :: Widget: Gtk, defect, P3)

42 Branch
defect

Tracking

()

REOPENED

People

(Reporter: ht990332, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: tpi:+)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150802040426

Steps to reproduce:

In gtk+3 builds using Adwaita theme, tabs aren't themed correctly. (they are themed correctly in gtk+2 builds so this is a visual egression).
I will attach
Attached image How Firefox tabs look.
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Summary: Tabs aren't themed correctly in gtk3 builds (42.0a1 nightly from source) → Tabs in Preferences -> Advanced -> 'Certificate Manager' are not themed correctly in gtk3 builds (42.0a1 nightly from source)
Note. Those are not the browser tabs but the tabs in 'Certificate Manager'.
Summary: Tabs in Preferences -> Advanced -> 'Certificate Manager' are not themed correctly in gtk3 builds (42.0a1 nightly from source) → Tabs in Preferences -> Advanced -> 'View Certificates' are not themed correctly in gtk3 builds (42.0a1 nightly from source)
Blocks: gtk3
Here with GTK+ 3.14.9, the fonts and background colors are not correct, but I do at least see a blue underline for the selected tab.

Which version of GTK+ was used for attachment 8642154 [details]?
Status: UNCONFIRMED → NEW
Ever confirmed: true
3.16.6
I can see the blue underline if I click on a tab. It just didn't highlight the initial tab for some reason.
This is what it looks like now. Apparently it is auto selecting a tab again.
http://i.imgur.com/mAAIw70.png
The background of the tab strip and the font color of the tab-title text are not themed correctly though.
Adwaita, the default gtk3 theme in Gnome, also draws a frame border around the tab content and tab strip.
See Also: → 1187263
Component: Widget: Gtk → Theme
Product: Core → Firefox
Why was this moved? I don't think we've touched the styling of this dialog in ages, so if it works in gtk2 this seems like a gtk3 issue.

If it matters, we're moving it into content in bug 1036815 for Firefox 51, so that might get rid of the problem.
Flags: needinfo?(jmathies)
(Also, that dialog is part of PSM and not Firefox...)
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(jmathies)
Resolution: --- → DUPLICATE
Duplicate of bug: 1036815
See Also: → 1271524
Duplicate of bug: 1049001
The fix for bug 1049001 doesn't seem to have helped here.
Status: RESOLVED → REOPENED
Component: Theme → Widget: Gtk
Priority: -- → P3
Product: Firefox → Core
Resolution: DUPLICATE → ---
See Also: → 1306425
Whiteboard: tpi:+
You need to log in before you can comment on or make changes to this bug.