Closed Bug 1190256 Opened 5 years ago Closed 5 years ago

Cannot find gtk3/setup.sh

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set
normal

Tracking

(firefox42 affected)

RESOLVED DUPLICATE of bug 1187222
Tracking Status
firefox42 --- affected

People

(Reporter: ewong, Unassigned)

References

Details

Currently busted on trunk:

export PANGO_LIBDIR=/builds/slave/c-cen-t-lnx/build/gtk3/usr/local/lib
------END_MK_OPTION
------BEGIN_MK_OPTION
export GDK_PIXBUF_MODULE_FILE=/builds/slave/c-cen-t-lnx/build/gtk3/usr/local/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache
------END_MK_OPTION
------BEGIN_MK_OPTION
export GDK_PIXBUF_MODULEDIR=/builds/slave/c-cen-t-lnx/build/gtk3/usr/local/lib/gdk-pixbuf-2.0/2.10.0/loaders
------END_MK_OPTION
------BEGIN_MK_OPTION
export LD_LIBRARY_PATH=/builds/slave/c-cen-t-lnx/build/gtk3/usr/local/lib
------END_MK_OPTION
/builds/slave/c-cen-t-lnx/build/build/unix/mozconfig.gtk: line 25: /builds/slave/c-cen-t-lnx/build/gtk3/setup.sh: No such file or directory
*** Fix above errors and then restart with\
               "make -f client.mk build"
make[1]: *** [configure] Error 1
make[1]: Leaving directory `/builds/slave/c-cen-t-lnx/build'
make: *** [/builds/slave/c-cen-t-lnx/build/objdir/Makefile] Error 2

My attempt at an explanation:

suite's nightly/debug/regular build mozconfigs refer to build/unix/mozconfig.gtk,
which is in the comm-central source.   The mozconfig.gtk file has
a line:

http://hg.mozilla.org/comm-central/file/eace0c64cb12/build/unix/mozconfig.gtk#l25

It doesn't exist with our gtk3.tar.xz (our tooltool repo is different
from Firefox's and TB's) so we fail at the compile step.

Solutions?

1) Include *all* needed mozconfig statements in the suite/config/mozconfigs/linux*/*.   This will *definitely* avoid all the needed pain with all these
relative path mozconfig sources; but, this pain will be replaced by the pain
of porting the necessary build/unix/* changes to our mozconfigs.  

2) copy firefox's gtk3.tar.xz to our tooltool repo.  (after looking at the
   setup.sh, it looks 'benign'... though I'm not 100% sure if it works
   on our linux* slaves.  (Callek?)
Depends on: 1190773
(In reply to Edmund Wong (:ewong) from comment #0)

> Solutions?
> 
> 1) Include *all* needed mozconfig statements in the
> suite/config/mozconfigs/linux*/*.   This will *definitely* avoid all the
> needed pain with all these
> relative path mozconfig sources; but, this pain will be replaced by the pain
> of porting the necessary build/unix/* changes to our mozconfigs.  
> 
> 2) copy firefox's gtk3.tar.xz to our tooltool repo.  (after looking at the
>    setup.sh, it looks 'benign'... though I'm not 100% sure if it works
>    on our linux* slaves.  (Callek?)

With bug 1184951 looming, I believe neither of those options are really
longterm.  

The best thing to do is simply use the new api.pub.build.mozilla.org repo
for our tooltool needs.
this bug will be 'fixed' by bug 1187222.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1187222
You need to log in before you can comment on or make changes to this bug.