Closed Bug 119030 Opened 19 years ago Closed 19 years ago

[RFE] Selective View Source

Categories

(SeaMonkey :: General, enhancement)

All
Linux
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 49721

People

(Reporter: corey, Assigned: asa)

Details

Here's an idea that hit me while browsing recently.  I don't know what the
implementation cost would be, but it's something I think would be handy, that
I've not seen in any browser yet.

Summary: The ability to highlight a section on your rendered webpage, and then
be able to view source of that particular section.  

Reason:
let's say you're looking at  a webpage, and want to "see
how this is done", or otherwise explore the HTML.  Would it be a handy
feature to be able to highlight a section of a rendered webpage, rather than
have to skim the whole page for what you were investigating. 

UI Implementation:  Highlight | Rt-Click | View selection source  (next to "View
Page Source")

Code Implementation:  ?

Result: 
I figure the result could be displayed, one of two ways -- either in a
window, a la View Source, containing just the bits that make up your
selection, or Load up the normal View Source window, with your section
highlighted/otherwise marked
Summary: Enhancement: Selective View Source → [RFE] Selective View Source
dup of 49721 "View Partial Source capability"

*** This bug has been marked as a duplicate of 49721 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.