Closed Bug 1190351 Opened 4 years ago Closed 4 years ago

Firefox is not pinned to the task bar after installing on Windows 10

Categories

(Firefox :: Installer, defect, P1)

40 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: phlsa, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

(Keywords: reproducible)

There seems to be an issue with the installer where Firefox isn't pinned to the task bar after the installation. Note that the »pin to task bar« option was checked in the installer options.

STR:
- Download Firefox 40 and install it through the stub installer
- Firefox launches after the installation
- Close Firefox

Expected:
- The Firefox icon should stay in the task bar

Actual:
- Firefox icon in the task bar disappears
I wonder if this regressed (possibly in our code, but more likely in Win10)? I've got Firefox pinned on both my Win10 machines, which were upgraded from earlier Win10 previews, and it's pinned on both. And I'm 98% sure I didn't do that myself.
We should investigate this promptly.
If we can't do anything about it immediately in the product, we could at least show something on the whatsnew page like Chrome supposedly does.
Blocks: 1191384
Rob, you're probably most familiar with this, are you able to help investigate what's happening?
Flags: needinfo?(robert.strong.bugs)
On PTO and I'll try to find time next week
Flags: needinfo?(robert.strong.bugs)
Any findings here yet? Also, might bug 1187306 be related here?
Flags: needinfo?(robert.strong.bugs)
Setting up a relatives laptop this evening, installed Firefox 40.0.2 on Windows 10. In the stub installer wizard there was an option pre-selected for 'Adding a taskbar shortcut'. Upon installation it was not added.
Keywords: reproducible
I added a hack in order to be able to add it and MS likely either prevented the ability or changed it enough to break the hack. No idea if bug 1187306 is related. I am atm too busy to investigate.
Flags: needinfo?(robert.strong.bugs)
Softvision was going to check this on 7/8/10, but if it's broken and our hack stopped working, we should remove this option from the installer. (And probably look into other ways of helping/suggesting how the user can do this, if we think it's important.)
I can reproduce this issue using the Firefox 40.0.3 stub installer on the following Windows 10 builds:
 • Pro x64, Build 10240 (RTM)
 • Pro x64, Build 10525 (Insider Build)
 • Pro x86, Build 10532 (latest Insider Build)

I suspect that upgrading from a previous Windows is not a mandatory step for this issue to reproduce, as some of the builds I've mentioned above were installed from a standalone Windows 10 *.iso.

As far as I can tell, Bug 1187306 is not related to this bug.

My attempts of isolating any specific conditions that might be causing this failed so far, e.g.:
 • Installed from stub using default installer settings
 • Installed from stub without placing a shortcut on the Desktop
 • Installed from stub without placing a shortcut in the Start Menu Programs folder
 • Installed from stub without placing shortcuts on Desktop and Start Menu Programs folder
 • Ran the stub as Administrator and installed using default installer settings
 • Ran the stub and updated an existing Firefox installation using default installer settings

I'll set up a clean RTM build on my test machine and also try upgrading from a Windows 7/8/8.1 setup, to see for sure if upgrading has any role in this.
This issue is reproducible on Windows 8.1 and Windows 7 as well and I think it might be related to the stub installer's "Make Firefox my default browser" option.

At this point, the "Make Firefox my default browser" option is not available at all on Windows 10 and Windows 8.1, here's an installer comparison: stub on Windows 10 [1] vs stub on Windows 7 [2]. 

The stub will not pin the application to the task bar if you're installing Firefox on Windows 7 with the "Make Firefox my default browser" option unchecked. Since that option is not available at all on Windows 8 and Windows 10, it might be the same case.

[1] http://i.imgur.com/qMCxsza.png
[2] http://i.imgur.com/OHzFVIz.png
Michael Verdi recently noticed that pinning seems to work fine when using the full installer, so it seems to be an issue with the stub (at least on Windows 7 and 8).
I just tested this in in Windows 7 and Windows 8.1:
* If I don't make Firefox default and the pin Firefox to the taskbar setting in the stub installer is left checked, Firefox will fail to be pinned. 
* If I make Firefox the default browser by leaving the checkbox in the installer checked or by using the modal prompt that comes up otherwise, Firefox is successfully pinned to the taskbar. 

I just filed Bug 1229626 as a followup.
Adding pinned items to the taskbar programmatically was never an officially supported feature of Windows [1], and rstrong's (actually pretty heroic) hack to make it work was intentionally disabled by Microsoft for Windows 10 (see [2]; our method is functionally equivalent to theirs). There doesn't seem to be any other way to reliably pin a shortcut to the taskbar programmatically, so I think we'll have to "fix" this by disabling the feature on Windows 10. I'll post a patch here that does that.

The problem on Windows 7 and 8/8.1 is different and can be addressed in bug 1229626.

[1] http://blogs.msdn.com/b/oldnewthing/archive/2014/12/30/10583474.aspx
[2] https://connect.microsoft.com/PowerShell/feedback/details/1609288/pin-to-taskbar-no-longer-working-in-windows-10
Assignee: nobody → mhowell
See Also: → 900635
As I understand it, we do not intend to fix this bug (for Windows 10). Bug 1229626 for older versions is still valid/fixable.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
FYI, Opera 12.18 is pinned the taskbar on Windows 10 somehow.
You need to log in before you can comment on or make changes to this bug.