Closed Bug 1190359 Opened 5 years ago Closed 4 years ago

sanitize.js should report errors in plug-in cookie clearing

Categories

(Toolkit :: Places, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: Yoric, Unassigned)

Details

For the moment, we ignore errors when we clear plug-in cookies.
Turning on error reporting when we clear plug-in cookies shows looots of errors on the console, because our test plug-in doesn't support clearing plug-in cookies.

We should find out what's wrong with the test plug-in, then turn on error reporting (and ideally fail-test-on-error) in sanitize.js.
the problem is that the pluginshost throws for anything, included if it's raining outside. No way to do this easily and plugins are going away, so we likely don't care.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.