Closed Bug 1190399 Opened 7 years ago Closed 11 months ago

With tab drag & drop, the new window appears off-screen

Categories

(Firefox :: Tabbed Browser, defect)

39 Branch
x86_64
Linux
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: vincent-moz, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

1. Open Firefox in safe mode.
2. Open a new tab.
3. Drag & drop this tab inside Firefox (to open it in a new window).


Actual results:

The new window appears completely off-screen. It is not possible to use it at all. I need to quit Firefox and restart it.

For instance, the geometry of this new window (as output by the xwininfo utility with the id obtained from the window list given by the FvwmWinList module of my window manager Fvwm): 2093x1773+3568+520 on a 3200x1800 screen.


Expected results:

The new Firefox window should appear within the screen limits.

Note: if I use the "New Window" function from the Firefox menu, there's no such problem because my Fvwm configuration lets me position the window if there isn't enough room (ActivePlacement feature).
Severity: normal → major
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
This might be related to tabbed browsing or something ??
QA Whiteboard: [bugday-20150803]
Component: Untriaged → Tabbed Browser

I tried to reproduce this on windows10 and ubuntu 20 and i saw no issues
since the bug is really old i will set it as resolved works for me.

Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → WORKSFORME

I can no longer reproduce this bug, but the window can appear slightly off-screen (still under Debian/unstable with the FVWM2 window manager). I wonder whether Firefox mishandles/ignores the size of the window decorations (title bar and window borders), as some other GTK-based applications have a similar issue when remembering the position of windows.

You need to log in before you can comment on or make changes to this bug.