Several errors shown in logs for Taskcluster B2G build for a green job

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jfrench, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
There seems to be some discrepancies in some job artifacts, at least on stage:

Steps to reproduce:
o open https://treeherder.allizom.org/#/jobs?repo=mozilla-inbound&revision=6c082c23b9c6&filter-searchStr=b2g%20L%20emulator%20opt
o select the last green successful B2G Emulator L opt job in the bottom row

o open that job's Logviewer link
https://treeherder.allizom.org/logviewer.html#?job_id=9061638&repo=mozilla-inbound

In it we have a job artifact with "error_count: 4" but "result: success". And a corresponding UI with green success but failure steps styled in green. Camd mentioned he thought it's possible another regex tweak may be required.

The corresponding Task for that job is here
https://tools.taskcluster.net/task-inspector/#vkMKiv7xRNaImRYUK5LgyQ/0
Those look like non-fatal errors to me
Pretty typical spam for all TC build jobs too

Comment 3

3 years ago
If these should result in the run being marked as unsuccessful, then this blocks bug 1048775.

If not, then the log output needs to be made less noisy, so it doesn't match the regex used by the log parser, and this bug blocks bug 910614.

Either way, this is a taskcluster issue, Treeherder is displaying this fine.
Component: Treeherder → Integration
Product: Tree Management → Taskcluster
Version: --- → unspecified

Updated

3 years ago
Summary: Success/Error state discrepancies on some TC jobs, on stage → Several errors shown in logs for Taskcluster B2G build for a green job
(Reporter)

Comment 4

3 years ago
Here's another variant perhaps worth including. This Logviewer view will look like a normal successful job, except unlike the first example, this one contains a 'show successful steps' which contains failed steps.
https://treeherder.allizom.org/logviewer.html#?job_id=9175861&repo=mozilla-inbound
(Reporter)

Comment 5

3 years ago
Oh and the above isn't a TC job. Let me know if I should split it off into a separate bug.

Comment 6

3 years ago
Yeah that's broken - but in Marionette could you file a new bug in Testing :: Marionette please? :-)
(Reporter)

Comment 7

3 years ago
Will do!
(Reporter)

Comment 8

3 years ago
(In reply to Ed Morley [:emorley] from comment #6)
> Yeah that's broken - but in Marionette could you file a new bug in Testing
> :: Marionette please? :-)

Done, bug 1191378.
Anything else to do here?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.