Firefox apparently uses text color from GTK theme, but not background color - result can be white on white...

RESOLVED DUPLICATE of bug 1158076

Status

()

RESOLVED DUPLICATE of bug 1158076
3 years ago
3 years ago

People

(Reporter: jonasthiem, Unassigned)

Tracking

42 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8642585 [details]
Screenshot from 2015-08-03 22:02:28.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150801030211

Steps to reproduce:

Please note this is a usability bug, probably not strictly a rendering bug. (see below for elaborations)



I enabled "Global dark theme" in Gnome 3.

This results in *tons* of websites now having unreadable HTML inputs.

Apparently, firefox tries to style the inputs according to the GTK theme, but sometimes only changes the foreground color, but not the background color of the input.

While this *might* be in part the pages fault (maybe they're enforcing a white background and not changing the text color), this results in extremely many pages being broken. In fact, it is so bad I can barely use the dark theme in overall.

Therefore, please consider your rendering engine not changing the text color from default black if the background color of a html input is altered by the page - or just stop styling in-the-page stuff according to the system theme in ways the page doesn't expect altogether, who needs that anyway.


Actual results:

I can't see what I'm typing in almost every second input field on the web I'm encountering.


Expected results:

I can still see what I'm typing everywhere.
(Reporter)

Comment 1

3 years ago
Random affected pages:

* your own mozilla firefox feedback survey at surveygizmo.com

* fpaste.org, pastebin.com

* Google (search bar sometimes has white on white text)

* youtube.com (search bar)

..

Even if there's a good reason to adjust the text color of elements in the page according to the system theme, the list of sites that breaks is waaay too long to make this a good idea in practice.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux

Comment 2

3 years ago
Duplicate of bug 1158076?
Component: Untriaged → Widget: Gtk
Flags: needinfo?(jonasthiem)
Product: Firefox → Core
(Reporter)

Comment 3

3 years ago
Yup looks like the same problem, except that with the dark Ubuntu theme I actually get white on white text >.> so it disappears fully in many places, not just almost.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jonasthiem)
Resolution: --- → DUPLICATE
Duplicate of bug: 1158076

Comment 4

3 years ago
This looks good now with FF Nightly
You need to log in before you can comment on or make changes to this bug.