Proxy with isExtensible trap can prevent the Object Inspector from inspecting object

RESOLVED DUPLICATE of bug 1274657

Status

()

Firefox
Developer Tools: Object Inspector
RESOLVED DUPLICATE of bug 1274657
3 years ago
2 years ago

People

(Reporter: Oriol, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20150803030207

Steps to reproduce:

Open the console and enter
> new Proxy(Object.create(null), {get: ()=>arguments, isExtensible: ()=>{} }).a

The console logs [object Arguments]. Click it.


Actual results:

The Object inspector can't inspect the Arguments object because of this internal error:
> error occurred while processing 'prototypeAndProperties:
> TypeError: proxy must report same extensiblitity as target


Expected results:

Object Inspector should be able to inspect the object.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Object Inspector
(Reporter)

Comment 1

2 years ago
A better testcase would be inspecting this object:

    [new Proxy({}, {isExtensible: ()=>{} })]

The issue is now fixed by bug 1274657.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274657
You need to log in before you can comment on or make changes to this bug.