If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[e10s] clicking link in fullscreen YouTube video doesn't exit fullscreen and then breaks fullscreen button

RESOLVED DUPLICATE of bug 1186890

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1186890
2 years ago
2 years ago

People

(Reporter: luke, Assigned: jimm)

Tracking

unspecified
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(e10s?)

Details

(Reporter)

Description

2 years ago
STR:
 - Go to https://www.youtube.com/watch?v=KdxEAt91D7k
 - Click YouTube fullscreen button to make the video go fullscreen
 - Skip (or watch) to end and click the "Watch previous video" rectangular link

After this, the browser navigates to the new youtube page bug stays in the video-fullscreen mode that has all chrome UI hidden.  (This is different than the normal browser Fullscreen mode that you get when clicking the Full Screen button which keeps the tab bar at the top and shows other browser UI when you move the mouse to the top.)  The fullscreen button on the new page silently fails to work.  Pressing Esc exits video-fullscreen mode and the YouTube fullscreen button works again.

There is no problem in a non-e10s window.  I currently am only able to test on OSX.  The problem doesn't reproduce for all YouTube annotation links, but it does reproduce consistently for several including the one above.
I am unable to reproduce this on Mac.  Luke, do you have add-ons installed? If so, please try reproducing with all of them disabled, that or test in a new profile.  Thanks.
Flags: needinfo?(luke)
(Reporter)

Comment 2

2 years ago
Zero addons and all plugins except the H.264 one disabled (incl. Flash).  This is on OSX 10.10.4.  Here's about:support:

Application Basics
------------------

Name: Firefox
Version: 42.0a1
Build ID: 20150804030204
Update Channel: nightly
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0
Multiprocess Windows: 1/1 (default: true)
Safe Mode: false

Extensions
----------

Graphics
--------

Asynchronous Pan/Zoom: wheel input enabled
Device ID: 0x0a29
GPU Accelerated Windows: 1/1 OpenGL (OMTC)
Supports Hardware H264 Decoding: false
Vendor ID: 0x10de
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 330M OpenGL Engine
windowLayerManagerRemote: true
AzureCanvasBackend: skia
AzureContentBackend: quartz
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 1

Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 4
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 7
browser.search.useDBForOrder: true
browser.sessionstore.restore_on_demand: false
browser.sessionstore.upgradeBackup.latestBuildID: 20150804030204
browser.startup.homepage_override.buildID: 20150804030204
browser.startup.homepage_override.mstone: 42.0a1
browser.tabs.remote.autostart: true
browser.tabs.remote.autostart.2: false
browser.tabs.warnOnClose: false
browser.tabs.warnOnOpen: false
dom.apps.reset-permissions: true
dom.ipc.processCount: 10
dom.mozApps.used: true
extensions.lastAppVersion: 42.0a1
media.gmp-gmpopenh264.lastUpdate: 1433219920
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150804030204
media.gmp-manager.lastCheck: 1438711050
media.webrtc.debug.aec_log_dir: /tmp/
media.webrtc.debug.log_file: /tmp/WebRTC.log
network.cookie.prefsMigrated: true
network.http.atsvc.enabled: false
network.http.atsvc.oe: false
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1438148755
places.history.expiration.transient_current_max_pages: 104019
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.default browser: 0
plugin.state.flash: 0
plugin.state.flip4mac wmv plugin: 0
plugin.state.googletalkbrowserplugin: 0
plugin.state.iphotophotocast: 0
plugin.state.o1dbrowserplugin: 0
plugin.state.quicktime plugin: 0
plugin.state.silverlight: 0
plugin.state.skypeforbusinessplugin: 0
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1437534564

Important Locked Preferences
----------------------------
Flags: needinfo?(luke)
Assignee: nobody → jmathies
(Assignee)

Updated

2 years ago
Flags: needinfo?(jmathies)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1186890
(Assignee)

Updated

2 years ago
Flags: needinfo?(jmathies)
You need to log in before you can comment on or make changes to this bug.