test_BufferingWait.html fails: waiting fired too early

RESOLVED FIXED in Firefox 43

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Jan Gerber, Assigned: Jan Gerber)

Tracking

Trunk
mozilla43
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox42 verified disabled, firefox43 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
test_BufferingWait.html currently fails since waiting is triggered at 0.66 instead of 0.7

Buffered ranges are up to 0.801000

848652032[7f6a26986380]: TrackBuffersManager(7f6a269be000:video/webm)::UpdateBufferedRanges: after video ranges=[(0.000000, 0.801000)]

And it looks like more frames are decoded:

TrackBuffersManager(7f6a269be000:video/webm)::ProcessFrames: Processing video/webm; codecs=vp8 frame(pts:767000 end:801000, dts:767000, duration:34000, kf:0)

Decoder=7f6a2682b8b0 playing video frame 733000 (id=12) (queued=21, state-machine=10, decoder-queued=11)
Is this still a bug with 43? Jean-Yves expects it to be.
Flags: needinfo?(j)
Priority: -- → P2
Summary: test_BufferingWait.html fails: waiting fired to early → test_BufferingWait.html fails: waiting fired too early
(Assignee)

Comment 2

2 years ago
Created attachment 8652258 [details] [diff] [review]
re-enable test_BufferingWait.html

Looks like this no longer fails. Lets enable it.
My guess is that this was fixed in bug 1194884 or bug 1195073
Attachment #8652258 - Flags: review?(giles)
(Assignee)

Updated

2 years ago
Assignee: nobody → j
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Flags: needinfo?(j)
(Assignee)

Comment 3

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4bc07a9785b5
Comment on attachment 8652258 [details] [diff] [review]
re-enable test_BufferingWait.html

Review of attachment 8652258 [details] [diff] [review]:
-----------------------------------------------------------------

Jean-Yves said he expected this bug to still be present, but I'm willing to give it a try. r=me with green try push.
Attachment #8652258 - Flags: review?(giles) → review+
(Assignee)

Comment 5

2 years ago
looks green: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4bc07a9785b5
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 6

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/43f374ed42a7
Keywords: checkin-needed
Depends on: 1199531
https://hg.mozilla.org/mozilla-central/rev/43f374ed42a7
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Blocks: 1197083
https://hg.mozilla.org/releases/mozilla-aurora/rev/a423bc891649
status-firefox42: affected → fixed
Backed out for a youtube playback regression. See Bug 1199573.
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bb661db5c6c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
status-firefox42: fixed → verified disabled
Resolution: --- → FIXED
pushed it as part of 
https://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?changeset=7437f28133fc
You need to log in before you can comment on or make changes to this bug.