If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Homescreen]Tap cancel button on edit bookmark view, device exits edit mode.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Lancy(Leave from Mozilla), Unassigned)

Tracking

({polish, regression})

unspecified
ARM
Gonk (Firefox OS)
polish, regression
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [systemsfe], permafail)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8642950 [details]
logcat.txt

[1.Description]:
[AriesKK v2.5 & FlameKK v2.5][Homescreen]Long press one shortcut on Homescreen to enter edit view, tap the name of the bookmark and tap cancel button on edit bookmark view, device exits edit mode.
See attachments:AriesKK_v2.5.3GP and logcat.txt
Occurrence time:23:04

[2.Testing Steps]: 
Precodition:One or more bookmarks have been added on Homescreen.

1.Enter Home Screen Edit Mode by long-tapping an icon. 
2.Tap on a bookmark 
3.Once the Edit View is displayed, tap on cancel button.  Or edit website name and tap done button.

[3.Expected Result]: 
3.Should go back to the edit mode.

[4.Actual Result]: 
3.It will go back to Homescreen and device exits edit mode.

[5.Reproduction build]: 
Device: Aries KK 2.5(Affected)
Build ID               20150801110932
Gaia Revision          2ca27bbdd84526c6a3b198d9cf10f2caff1dadde
Gaia Date              2015-07-31 08:23:31
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/32712cd01159
Gecko Version          42.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150801.105449
Firmware Date          Sat Aug  1 10:54:56 UTC 2015
Bootloader             s1

Device: Flame KK 2.2(Unaffected)
Build ID               20150803032504
Gaia Revision          f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gaia Date              2015-07-31 13:20:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/429b9d2d4566
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150803.072845
Firmware Date          Mon Aug  3 07:28:58 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:Flame KK 2.5(Affected)
Build ID               20150803150205
Gaia Revision          dbacf8364f4505d021b7d8fb9cabea325004dbcc
Gaia Date              2015-08-03 16:38:49
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abc56d57f6e1
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150803.183149
Firmware Date          Mon Aug  3 18:32:00 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
11858
(Reporter)

Comment 1

2 years ago
Created attachment 8642951 [details]
AriesKK_v2.5.3GP
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected

Comment 2

2 years ago
Is this a regression? If so, can we get a window? Thanks.
Keywords: qawanted

Comment 3

2 years ago
Ah, I missed the flags, adding window-wanted keyword.
Keywords: qawanted → regression, regressionwindow-wanted

Updated

2 years ago
QA Contact: mshuman
This issue seems to be caused by:
Bug 1144132 - [Activity] Properly adjust the priority of activity openers to prevent them from being killed by the LMK when they are hidden

B2g-inbound Regression Window:

Last Working 
Environmental Variables:
Device: Flame 2.5
Build ID: 20150622170244
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 2ab4034b2cc1
Version: 41.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 2.5
BuildID: 20150623190325
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 5a3ee6baf143
Version: 41.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue does NOT reproduce
Gaia: c4d3b8fd78bcd7eff1b127060ec6490a891b7a35
Gecko: 5a3ee6baf143

First Broken gaia / Last Working gecko - Issue DOES reproduce
Gaia: eb0d4aefa62b20420d6fa0642515a110daca5d97
Gecko: 2ab4034b2cc1

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/c4d3b8fd78bcd7eff1b127060ec6490a891b7a35...eb0d4aefa62b20420d6fa0642515a110daca5d97
Blocks: 1144132
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Allison, can you take a look at this or assign it to the correct person? The author of the landing for bug 1144132 which might have caused this to occur is no longer available.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(ashiue)

Comment 6

2 years ago
[Blocking Requested - why for this release]:
Regression issue.

Hi Gabriele, since this issue might be caused by bug 1144132, could you please help to take a look at this issue? Thank you.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ashiue) → needinfo?(gsvelto)
Whiteboard: [2.5-aries-test-run-1] → [2.5-aries-test-run-1][systemsfe]
Is this a blocker for UX?
Flags: needinfo?(firefoxos-ux-bugzilla)
Setting to non blocking for now until we hear back from UX.
blocking-b2g: 2.5? → ---
Keywords: polish
I'm pretty sure edit mode is going away so it seems to me this bug is moot? Am I missing something?
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(chrislord.net)
OK, this one is rather tricky and is an effect of the way we handle application visibility after bug 1144132. Previous to that bug activities would not alter the visibility of the calling application, i.e. the application would remain visible (document.hidden === false) even though it had been obviously hidden. This was a hack to workaround issues in the process priority manager. What's happening here is that the gaia_grid shared code exits edit-mode when the application becomes hidden, see here:

https://github.com/mozilla-b2g/gaia/blob/d5fd0536f54990c1d8649aa7be8c0252793ab6bd/shared/elements/gaia_grid/js/grid_dragdrop.js#L795

So in this case the following is happening:

1. We enter edit mode
2. We open an activity to rename the link
3. The homescreen is marked as hidden by the window manager
4. gaia_grid closes edit-mode in response to the visibilitychange event
5. Once we go back to the homescreen we find that edit-mode has been quit

I'm not sure what a robust way for fixing this would be. In part it's a UX issue since any transition that makes the app using gaia_grid hidden will exit edit-mode.
Flags: needinfo?(gsvelto)

Updated

2 years ago
Flags: needinfo?(chrislord.net)
(Reporter)

Updated

2 years ago
Whiteboard: [2.5-aries-test-run-1][systemsfe] → [2.5-aries-test-run-1][systemsfe][2.5-aries-test-run-2]

Updated

2 years ago
Whiteboard: [2.5-aries-test-run-1][systemsfe][2.5-aries-test-run-2] → [systemsfe], permafail
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.