Setting Mozilla as .html handler loses third party menuitems added to the [ie]htmlfile context menu

RESOLVED WONTFIX

Status

Core Graveyard
File Handling
--
minor
RESOLVED WONTFIX
17 years ago
2 years ago

People

(Reporter: Aurle, Assigned: Bill Law)

Tracking

({qawanted, relnote})

Trunk
Future
x86
Windows 98
qawanted, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When you accept Mozilla to be your default browser application all the context
associations that would appear when you clicked on an HTML file with your right
mouse button in widows explorer dissappear. The only remaining one is edit which
launches Composer. Associations for Dreamweaver, Plucker, and Frontpage
dissappeared.  Just because one decides to let Mozzilla be their default browser
shouldn't mean composer becomes your default html editor. It should be added as
an additional option perhaps, leaving the other associations in tact.

Comment 1

17 years ago
interesting idea, but this is a bug in the way windows handles associations.  
We could try to take over the generic html association but by convention that's 
owned by ie and each application should use its own key for a file type.  We 
could do migration, but that'd be messy.
Assignee: asa → law
Component: Browser-General → File Handling
QA Contact: doronr → sairuh
(Reporter)

Comment 2

17 years ago
Ahhh, I see.  Based on the additional comment I was able to understand the
problem a little better.  After that I was able to just go into the file
associations and copy the associations for Plucker and Dreamweaver from the txt
group and paste them into the Mozilla HTML group.  It fixed my problem ok, but
it would still be better if it was not neccesary. When it first happened I was
scrathing my head wondering what happened.  I would have no idea how to make it
so it didn't happen so I will take your word for it that it is really a windows
thing (not surprising) and Migration would be messy.

Comment 3

17 years ago
:) ok, at the very least we should relnote this (not that anyone reads 
relnotes).  beyond that it's probably worth discussing.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: relnote
Summary: Clears html editor context associations → Setting Mozilla as .html handler loses third party menuitems added to the [ie]htmlfile context menu
Keywords: qawanted
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: --- → Future
QA Contact: sairuh → petersen
no dupes in 7 years and it's a win32 os limitation
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.