Closed Bug 1190989 Opened 4 years ago Closed 4 years ago

Add "Import" slide to first run

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1199859
Tracking Status
firefox42 --- affected

People

(Reporter: liuche, Unassigned)

References

(Blocks 1 open bug)

Details

We've talked about adding an Import Screen to first run and we have some prototypes in bug 1172623, but it's time to file an actual bug for this work. This depends on bug 1186037 so we can actually reliably import.
I just want to bring up that the content provider for bookmarks and history has been removed from Android M (see bug 1183069 and bug 1183559). So we shouldn't show this import screen for devices running Android M+.
Thanks Sebastian for bringing this up, this is important information, do you know why they've done this and if this will be removed  for sure in the final M version? 

Before investigating any further, we should figure out how often that feature is used (maybe some might not know about that), and depending on that figure out if there is anything we can build to continue to support the import on M+.
Flags: needinfo?(s.kaspari)
(In reply to Barbara Bermes [:bbermes] from comment #2)
> Thanks Sebastian for bringing this up, this is important information, do you
> know why they've done this and if this will be removed  for sure in the
> final M version?

I don't have an official statement. I can just quote from this[1] bug in the Android preview bug tracker:

> Global bookmarks are no longer available.  They haven't really done
> anything for a long time anyway, since browsers these days generally keep
> their own internal bookmarks data rather than putting them in the global
> provider.  Apps using the global provider should likewise switch to
> maintaining them internally.

This is more or less confirming what we have seen too: Most browsers and sometimes even the stock browser do not save their bookmarks in this public content provider (See bug 1186037 and bug 963661).

Looking at the version distribution dashboard[2] and seeing Lollipop at 15.5% after almost a year, I think we still have a lot of time until M will reach wide distribution and can still build a great experience for everyone < M. But we probably shouldn't build big features on top of that.

> Before investigating any further, we should figure out how often that
> feature is used (maybe some might not know about that), and depending on
> that figure out if there is anything we can build to continue to support the
> import on M+.

Richard just found this other bookmark provider in the Android source code[3]. We should investigate if this can be used. We could also go ahead and investigate if any other browser's bookmarks can be accessed through their own content provider (Unlikely but we should investigate). Right now we are just importing from the public provider of the system and this one seems to go away. But this should all happen in an other bug. :-)

[1]: https://code.google.com/p/android-developer-preview/issues/detail?id=2805
[2]: https://developer.android.com/about/dashboards/index.html
[3]: https://android.googlesource.com/platform/packages/apps/Browser.git/+/android-m-preview/src/com/android/browser/provider/BrowserProvider2.java
Flags: needinfo?(s.kaspari)
Is there anything left to do here, or can we close this bug?
Flags: needinfo?(liuche)
Added in bug 1199859, so I'll mark this as a dupe as the code is implemented in that bug.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(liuche)
Resolution: --- → DUPLICATE
Duplicate of bug: 1199859
You need to log in before you can comment on or make changes to this bug.