Making a local device server farm available across Mozilla intranet

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jonalmeida, Assigned: arzhel)

Tracking

Details

(Reporter)

Description

3 years ago
On the mobile team in SF, we currently have an experimental setup of a device farm for all our android devices to allow them to be controlled from one location via the browser (See: https://github.com/openstf/stf). Currently, our setup includes a static ip for the machine which is accessed by it's local DNS alias. 

We want to allow our team who work in other offices in Mozilla and remotely full-time to access these devices. To do that now, they need to always be connected to the Mozilla VPN which isn't inconvenient since this is the only use case for them to use the VPN.

Is it possible to extend access to this server across Mozilla's intranet to so that those connected via 'Mozilla' wifi in other locations can access it? (It makes sense for those outside to use the VPN for now, until we have a solution like persona for access.
Netops should evaluate this request. I believe they have infrastructure set up for this kind of stuff already in other vlans.
Assignee: infra → network-operations
Component: Infrastructure: Other → NetOps: Office Other
QA Contact: jdow → jbarnell
(In reply to Jonathan Almeida (:jonalmeida) from comment #0)
> On the mobile team in SF, we currently have an experimental setup of a
> device farm for all our android devices to allow them to be controlled from
> one location via the browser (See: https://github.com/openstf/stf).
> Currently, our setup includes a static ip for the machine which is accessed
> by it's local DNS alias. 
> 
> We want to allow our team who work in other offices in Mozilla and remotely
> full-time to access these devices. To do that now, they need to always be
> connected to the Mozilla VPN which isn't inconvenient since this is the only
> use case for them to use the VPN.
> 
> Is it possible to extend access to this server across Mozilla's intranet to
> so that those connected via 'Mozilla' wifi in other locations can access it?
> (It makes sense for those outside to use the VPN for now, until we have a
> solution like persona for access.

Questions:

1.  Can you please provide a description of the devices we're talking about (model, how the access the network, length of time you expect this to be in production, etc).

2.  Is there a specific group of users we're talking about here?
(Reporter)

Comment 3

3 years ago
(In reply to James Barnell [:jbarnell] from comment #2)
> 1.  Can you please provide a description of the devices we're talking about
> (model, how the access the network, length of time you expect this to be in
> production, etc).

- This device farm is for Android devices ranging from Android 2.3+. For now, I've connected a Nexus 5, Nexus 9, Galaxy Nexus, Galaxy Tab and Transformer Prime. Since each device is physically present in SF, it will have access to the network via Mozilla Guest.

Currently an experiment to share use of our Android devices with those working remotely as opposed to shipping out devices by courier. There are also deployment notes[1] that can be used to deploy the service in multiple locations to share devices from more than one location (will only get to this step if we see how useful making the SF devices end up being).

> 2.  Is there a specific group of users we're talking about here?

This is meant to be accessible by only the mobile development team (Firefox for Android & iOS). There is an authentication system that is used for storing user settings, which can be used with OAuth or LDAP login[2].


[1]: https://github.com/openstf/stf/blob/master/doc/DEPLOYMENT.md
[2]: https://github.com/openstf/stf/issues/47#issuecomment-127509404
(Reporter)

Updated

3 years ago
Summary: Making a local device farm server available across Mozilla intranet → Making a local device server farm available across Mozilla intranet
(Reporter)

Comment 4

3 years ago
Adding needinfo in case jbarnell doesn't see this.
Flags: needinfo?(jbarnell)
(Assignee)

Comment 5

3 years ago
Jonathan, do you have some example hostnames/IPs for those devices?
Assignee: network-operations → arzhel
(Assignee)

Comment 6

3 years ago
Talked to Jonathan over IRC, I confirmed that was working from other offices including Portland.

Please reopen if there is any other issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jbarnell)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.