Divs with overflow-y: hidden and truncated content added to the tab order

RESOLVED DUPLICATE of bug 626919

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 626919
3 years ago
3 years ago

People

(Reporter: Chris Bradley, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8643317 [details]
test_overflow_tab_order.html

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150704143817

Steps to reproduce:

1. Load the sample file
2. Place focus on the first text box.
3. Press the TAB key.


Actual results:

Focus is on the wrapping div around the second textbox.


Expected results:

Focus should be on the second field.
(Reporter)

Comment 1

3 years ago
This occurs when the div wrapping the input is set to "overflow-y: hidden" and has a smaller height than the contents.

The behaviour would make sense if overflow-y was set to "scroll" or "auto", since you would then be able to scroll the div with the keyboard while it is in focus. However, this can not be done when it is set to "hidden".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626919
You need to log in before you can comment on or make changes to this bug.