Closed Bug 1191094 Opened 4 years ago Closed 2 years ago

[Window Mgmt] The last time card view of app would show at the transition of current card view

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: KTucker, Unassigned)

References

()

Details

(Keywords: polish, Whiteboard: [2.5-Daily-Testing][Spark][systemsfe])

Attachments

(1 file)

If the user goes into card view on the "Import Contacts" screen, goes back to the "Settings" page and goes into card view once again, they will notice the "Settings" screen will transition to the "Import Contacts" screen when going into card view.

Repro Steps:
1) Update a Flame to 20150804030213
2) Open "Contacts". 
3) Tap on the "Settings" icon.
4) Tap on "Import Contacts".
5) Press and hold the "Home" button to enter card view on the "Import Contacts" page.
6) Tap on the "Import Contacts" card to return to the page and then back out to contacts "Settings" page. 
7) Enter card view while on the "Settings" page and pay close attention to the transition. 

Actual:
The "Import Contacts" page will appear when transitioning to card view on the contacts "Settings" page.

Expected:
The "Settings" page transitions smoothly when going into card view.

Notes:

Environmental Variables:
Device: Flame 2.5 (Full Flash)(KK)(319mb)
Build ID: 20150804030213
Gaia: caba8b26c52d3c771e9ea6fe288acdaf74c7707e
Gecko: 5b54831761b1
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 100%
See attached: Logcat, Video
This also occurs on Aries master, Flame 2.2 and Flame 

The contacts "Settings" page transitions to the "Import Contacts" page when going into card view. 

Environmental Variables:
Device: Aries 2.5
Build ID: 20150803200840
Gaia: dbacf8364f4505d021b7d8fb9cabea325004dbcc
Gecko: abc56d57f6e1
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150804032504
Gaia: f8b119ac30e97df991c97682ac4d4f9ca22e1793
Gecko: 0c7a85251e10
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1 (Full Flash)(KK)(319mb)
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [2.5-Daily-Testing][Spark]
Correction to the above comment. This does not occur on Flame 2.1 but I think that card view was reworked so this is not a regression. 

Device: Flame 2.1 (Full Flash)(KK)(319mb)
BuildID: 20150724001207
Gaia: 9dba58d18006e921546cec62c76074ce81e16518
Gecko: 41e10c6740be
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
NI component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(ashiue)
[Blocking Requested - why for this release]:
Obvious problem.

Since all apps have this problem, update the title.
The last time card view of app would show at the transition of current card view.

Hi Sam, could you help to check this issue? Thanks.
blocking-b2g: --- → 2.5?
Flags: needinfo?(ashiue) → needinfo?(sfoster)
Summary: [Window Mgmt] Going to card view on the import contacts screen causes card view transition issues → [Window Mgmt] The last time card view of app would show at the transition of current card view
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][systemsfe]
Yeah it looks like when we begin the transition to card view and switch to using the identification overlay, we're seeing an old screenshot that doesnt capture the activity window. Longer term we want to avoid using the static screenshot entirely here. But short-term we should be able to invalidate the old screenshot and get a new one before we transition. 

I'm not sure I would block on this, but I'll leave the nomination on there for others to chime in.
Flags: needinfo?(sfoster)
Priority: -- → P2
blocking-b2g: 2.5? → ---
Keywords: polish
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.