Intermittent test_peerConnection_setLocalAnswerInStable.html | application crashed [@ libc-2.15.so + 0x136b9d]

RESOLVED DUPLICATE of bug 1194397

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1194397
2 years ago
2 years ago

People

(Reporter: KWierso, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

2 years ago
15:21:18 INFO - 3523 INFO TEST-START | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html
15:21:18 INFO - TEST DEVICES: Using media devices:
15:21:18 INFO - audio: Sine source at 440 Hz
15:21:18 INFO - video: Dummy video device
15:21:18 INFO - Timecard created 1438726878.053872
15:21:18 INFO - Timestamp | Delta | Event | File | Function
15:21:18 INFO - ========================================================================================================
15:21:18 INFO - 0.005254 | 0.005254 | Constructor Completed | PeerConnectionImpl.cpp:403 | PeerConnectionImpl
15:21:18 INFO - 0.006624 | 0.001370 | Initializing PC Ctx | PeerConnectionImpl.cpp:720 | Initialize
15:21:18 INFO - 0.323717 | 0.317093 | Create Offer | PeerConnectionImpl.cpp:1451 | CreateOffer
15:21:18 INFO - 0.333311 | 0.009594 | Set Local Description | PeerConnectionImpl.cpp:1537 | SetLocalDescription
15:21:18 INFO - 0.339217 | 0.005906 | Set Local Description | PeerConnectionImpl.cpp:1537 | SetLocalDescription
15:21:18 INFO - 0.843865 | 0.504648 | Destructor Invoked | PeerConnectionImpl.cpp:415 | ~PeerConnectionImpl
15:21:18 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:429: ~PeerConnectionImpl: PeerConnectionImpl destructor invoked for 9bf3c6684a4e2e6a
15:21:18 INFO - Timecard created 1438726878.070015
15:21:18 INFO - Timestamp | Delta | Event | File | Function
15:21:18 INFO - ========================================================================================================
15:21:18 INFO - 0.002132 | 0.002132 | Constructor Completed | PeerConnectionImpl.cpp:403 | PeerConnectionImpl
15:21:18 INFO - 0.003530 | 0.001398 | Initializing PC Ctx | PeerConnectionImpl.cpp:720 | Initialize
15:21:18 INFO - 0.841385 | 0.837855 | Destructor Invoked | PeerConnectionImpl.cpp:415 | ~PeerConnectionImpl
15:21:18 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:429: ~PeerConnectionImpl: PeerConnectionImpl destructor invoked for c2b0ba417ae0c909
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:402: PeerConnectionImpl: PeerConnectionImpl constructor for
15:21:19 INFO - (ice/WARNING) ICE(PC:1438726879156034 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn): No STUN servers specified
15:21:19 INFO - (ice/NOTICE) ICE(PC:1438726879156034 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn): No TURN servers specified
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:402: PeerConnectionImpl: PeerConnectionImpl constructor for
15:21:19 INFO - (ice/WARNING) ICE(PC:1438726879170042 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn): No STUN servers specified
15:21:19 INFO - (ice/NOTICE) ICE(PC:1438726879170042 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn): No TURN servers specified
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionMedia] PeerConnectionMedia.cpp:173: OnProxyAvailable: Proxy Available: 0
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionMedia] PeerConnectionMedia.cpp:189: SetProxyOnPcm: Had proxyinfo
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionMedia] PeerConnectionMedia.cpp:173: OnProxyAvailable: Proxy Available: 0
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionMedia] PeerConnectionMedia.cpp:189: SetProxyOnPcm: Had proxyinfo
15:21:19 INFO - JavaScript error: chrome://browser/content/webrtcIndicator.js, line 51: TypeError: gStringBundle is undefined
15:21:19 INFO - -1308018496[b1e310c0]: Cannot set local answer in state stable
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:1582: SetLocalDescription: pc = 4723c95062839257, error = Cannot set local answer in state stable
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:2433: CloseInt: Closing PeerConnectionImpl 4723c95062839257; ending call
15:21:19 INFO - -1308018496[b1e310c0]: [1438726879156034 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn]: stable -> closed
15:21:19 INFO - -1308018496[b1e310c0]: [main|PeerConnectionImpl] PeerConnectionImpl.cpp:2433: CloseInt: Closing PeerConnectionImpl e1f2607b63ddf843; ending call
15:21:19 INFO - -1308018496[b1e310c0]: [1438726879170042 (id=2147487252 url=http://mochi.test:8888/tests/dom/media/tests/mochitest/test_peerConnection_setLocalAnswerIn]: stable -> closed
15:21:19 INFO - MEMORY STAT | vsize 1035MB | residentFast 157MB | heapAllocated 86MB
15:21:19 INFO - firefox: /build/buildd/cairo-1.10.2/src/cairo-array.c:320: _cairo_array_allocate: Assertion `array->num_elements + num_elements <= array->size' failed.
15:21:20 INFO - [Child 1932] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-in-lx-0000000000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 1762
15:21:20 INFO - [Child 1932] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-in-lx-0000000000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 1762
15:21:20 INFO - TEST-INFO | Main app process: exit 11
15:21:20 INFO - 3524 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | A valid string reason is expected
15:21:20 INFO - 3525 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Reason cannot be empty 
 15:21:20 INFO - 3526 INFO Network setup is not required
15:21:20 INFO - 3527 INFO Creating PeerConnectionWrapper (pcLocal)
15:21:20 INFO - 3528 INFO Creating PeerConnectionWrapper (pcRemote)
15:21:20 INFO - 3529 INFO Run step 1: PC_SETUP_SIGNALING_CLIENT
15:21:20 INFO - 3530 INFO Run step 2: PC_LOCAL_SETUP_ICE_LOGGER
15:21:20 INFO - 3531 INFO Run step 3: PC_REMOTE_SETUP_ICE_LOGGER
15:21:20 INFO - 3532 INFO Run step 4: PC_LOCAL_SETUP_SIGNALING_LOGGER
15:21:20 INFO - 3533 INFO Run step 5: PC_REMOTE_SETUP_SIGNALING_LOGGER
15:21:20 INFO - 3534 INFO Run step 6: PC_LOCAL_SETUP_ADDSTREAM_HANDLER
15:21:20 INFO - 3535 INFO Run step 7: PC_REMOTE_SETUP_ADDSTREAM_HANDLER
15:21:20 INFO - 3536 INFO Run step 8: PC_LOCAL_CHECK_INITIAL_SIGNALINGSTATE
15:21:20 INFO - 3537 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Initial local signalingState is 'stable'
15:21:20 INFO - 3538 INFO Run step 9: PC_REMOTE_CHECK_INITIAL_SIGNALINGSTATE
15:21:20 INFO - 3539 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Initial remote signalingState is 'stable'
15:21:20 INFO - 3540 INFO Run step 10: PC_LOCAL_CHECK_INITIAL_ICE_STATE
15:21:20 INFO - 3541 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Initial local ICE connection state is 'new'
15:21:20 INFO - 3542 INFO Run step 11: PC_REMOTE_CHECK_INITIAL_ICE_STATE
15:21:20 INFO - 3543 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Initial remote ICE connection state is 'new'
15:21:20 INFO - 3544 INFO Run step 12: PC_LOCAL_GUM
15:21:20 INFO - 3545 INFO Get 1 local streams
15:21:20 INFO - 3546 INFO Call getUserMedia for {"audio":true}
15:21:20 INFO - 3547 INFO PeerConnectionWrapper (pcLocal) gUM local stream {c7aee5a7-9dbd-47d6-a0e7-1e08241facbf} with audio track {aaaa1e2b-523f-47f7-9909-b91cb7f1b91c}
15:21:20 INFO - 3548 INFO Got media stream: audio (local)
15:21:20 INFO - 3549 INFO PeerConnectionWrapper (pcLocal): "onnegotiationneeded" event fired
15:21:20 INFO - 3550 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | addTrack returns sender
15:21:20 INFO - 3551 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | track has id
15:21:20 INFO - 3552 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | track has kind
15:21:20 INFO - 3553 INFO Run step 13: PC_REMOTE_GUM
15:21:20 INFO - 3554 INFO Get 1 local streams
15:21:20 INFO - 3555 INFO Call getUserMedia for {"audio":true}
15:21:20 INFO - 3556 INFO PeerConnectionWrapper (pcRemote) gUM local stream {e01b4f50-61a0-4490-b227-67bbc7bf69b4} with audio track {f2e651e6-13dd-435f-b0dd-4980fb963016}
15:21:20 INFO - 3557 INFO Got media stream: audio (local)
15:21:20 INFO - 3558 INFO PeerConnectionWrapper (pcRemote): "onnegotiationneeded" event fired
15:21:20 INFO - 3559 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | addTrack returns sender
15:21:20 INFO - 3560 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | track has id
15:21:20 INFO - 3561 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | track has kind
15:21:20 INFO - 3562 INFO Run step 14: PC_LOCAL_SETUP_ICE_HANDLER
15:21:20 INFO - 3563 INFO Run step 15: PC_REMOTE_SETUP_ICE_HANDLER
15:21:20 INFO - 3564 INFO Run step 16: PC_LOCAL_STEEPLECHASE_SIGNAL_EXPECTED_LOCAL_TRACKS
15:21:20 INFO - 3565 INFO Run step 17: PC_REMOTE_STEEPLECHASE_SIGNAL_EXPECTED_LOCAL_TRACKS
15:21:20 INFO - 3566 INFO Run step 18: PC_LOCAL_GET_EXPECTED_REMOTE_TRACKS
15:21:20 INFO - 3567 INFO Run step 19: PC_REMOTE_GET_EXPECTED_REMOTE_TRACKS
15:21:20 INFO - 3568 INFO Run step 20: PC_LOCAL_CREATE_OFFER
15:21:20 INFO - 3569 INFO Got offer: {"type":"offer","sdp":"v=0\r\no=mozilla...THIS_IS_SDPARTA-42.0a1 5649053500254136689 0 IN IP4 0.0.0.0\r\ns=-\r\nt=0 0\r\na=fingerprint:sha-256 D8:DB:9B:6C:DD:11:A4:EB:12:E2:00:37:E9:3B:96:75:5A:52:2A:CE:22:2A:77:69:18:1F:F4:B6:B6:52:92:75\r\na=ice-options:trickle\r\na=msid-semantic:WMS *\r\nm=audio 9 RTP/SAVPF 109 9 0 8\r\nc=IN IP4 0.0.0.0\r\na=sendrecv\r\na=extmap:1 urn:ietf:params:rtp-hdrext:ssrc-audio-level\r\na=ice-pwd:b7d18b0ccd6f1b5ae6fb1b74a161db37\r\na=ice-ufrag:f8959c6f\r\na=mid:sdparta_0\r\na=msid:{c7aee5a7-9dbd-47d6-a0e7-1e08241facbf} {aaaa1e2b-523f-47f7-9909-b91cb7f1b91c}\r\na=rtcp-mux\r\na=rtpmap:109 opus/48000/2\r\na=rtpmap:9 G722/8000/1\r\na=rtpmap:0 PCMU/8000\r\na=rtpmap:8 PCMA/8000\r\na=setup:actpass\r\na=ssrc:3523898621 cname:{37a62086-6f0d-4ade-b20d-b267257b7123}\r\n"}
15:21:20 INFO - 3570 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Local create offer does not change signaling state
15:21:20 INFO - 3571 INFO Run step 21: PC_LOCAL_SET_LOCAL_ANSWER
15:21:20 INFO - 3572 INFO PeerConnectionWrapper (pcLocal): As expected, failed to set the local description
15:21:20 INFO - 3573 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | Error is InvalidStateError
15:21:20 INFO - 3574 INFO TEST-FAIL | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | The author of the test has indicated that flaky timeouts are expected. Reason: WebRTC inherently depends on timeouts
15:21:20 INFO - 3575 INFO Closing peer connections
15:21:20 INFO - 3576 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | iceConnectionState should not be undefined
15:21:20 INFO - 3577 INFO PeerConnectionWrapper (pcLocal): oniceconnectionstatechange fired, new state is: closed
15:21:20 INFO - 3578 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | PeerConnectionWrapper (pcLocal): legal ICE state transition from new to closed
15:21:20 INFO - 3579 INFO PeerConnectionWrapper (pcLocal): "onsignalingstatechange" event fired
15:21:20 INFO - 3580 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | signalingState is closed
15:21:20 INFO - 3581 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | PeerConnectionWrapper (pcLocal): legal signaling state transition from stable to closed
15:21:20 INFO - 3582 INFO PeerConnectionWrapper (pcLocal): Closed connection.
15:21:20 INFO - 3583 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | iceConnectionState should not be undefined
15:21:20 INFO - 3584 INFO PeerConnectionWrapper (pcRemote): oniceconnectionstatechange fired, new state is: closed
15:21:20 INFO - 3585 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | PeerConnectionWrapper (pcRemote): legal ICE state transition from new to closed
15:21:20 INFO - 3586 INFO PeerConnectionWrapper (pcRemote): "onsignalingstatechange" event fired
15:21:20 INFO - 3587 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | signalingState is closed
15:21:20 INFO - 3588 INFO TEST-PASS | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | PeerConnectionWrapper (pcRemote): legal signaling state transition from stable to closed
15:21:20 INFO - 3589 INFO PeerConnectionWrapper (pcRemote): Closed connection.
15:21:20 INFO - 3590 INFO TEST-FAIL | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | The author of the test has indicated that flaky timeouts are expected. Reason: WebRTC inherently depends on timeouts
15:21:20 WARNING - TEST-UNEXPECTED-FAIL | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | application terminated with exit code 11 
 15:21:20 INFO - runtests.py | Application ran for: 0:39:25.984674
15:21:20 INFO - zombiecheck | Reading PID log: /tmp/tmpaZNkq_pidlog
15:21:20 INFO - ==> process 1873 launched child process 1932
15:21:20 INFO - ==> process 1873 launched child process 2869
15:21:20 INFO - ==> process 1873 launched child process 2902
15:21:20 INFO - ==> process 1873 launched child process 2921
15:21:20 INFO - ==> process 1873 launched child process 2985
15:21:20 INFO - ==> process 1873 launched child process 3016
15:21:20 INFO - ==> process 1873 launched child process 7636
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 1932
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 2869
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 2902
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 2921
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 2985
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 3016
15:21:20 INFO - zombiecheck | Checking for orphan process with PID: 7636
15:21:20 INFO - mozcrash Downloading symbols from: https://queue.taskcluster.net/v1/task/qg_kLVkeRImZXYK5z13jyw/artifacts/public/build/firefox-42.0a1.en-US.linux-i686.crashreporter-symbols.zip
15:21:46 INFO - mozcrash Saved minidump as /builds/slave/test/build/blobber_upload_dir/27207201-53ca-7cf1-57e44830-743caf33.dmp
15:21:46 INFO - mozcrash Saved app info as /builds/slave/test/build/blobber_upload_dir/27207201-53ca-7cf1-57e44830-743caf33.extra
15:21:46 WARNING - PROCESS-CRASH | dom/media/tests/mochitest/test_peerConnection_setLocalAnswerInStable.html | application crashed [@ libc-2.15.so + 0x136b9d]
Comment hidden (Treeherder Robot)
Crash is deep in gfx (likely the same bug reported in other tests with crashes deep in gdk/etc)
Component: WebRTC → Graphics
Whiteboard: [gfx-noted]
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1194397
You need to log in before you can comment on or make changes to this bug.