Closed Bug 1191209 Opened 5 years ago Closed 5 years ago

Turning on/off an IDL file needs a clobber

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox42 fixed)

RESOLVED FIXED
mozilla42
Tracking Status
firefox42 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

This has happened repeatedly when enabling/disabling Gtk+3 on some platforms, because Gtk+3 have, for instance, nsIApplicationChooser.idl that Gtk+2 builds don't have.

The issue is kind of the same thing that led to the fixup in bug 1114669: https://hg.mozilla.org/mozilla-central/rev/cfdcb37cc953

The problem is that the IDL was previously in the tree, so it's actually older than the xpt target, so the xpt and the headers are not (re)built.
Assignee: nobody → mh+mozilla
Attachment #8643606 - Flags: review?(gps)
The attached patch 0001-Bug-1191212-Force-a-value-for-PKG_CONFIG-when-buildi.patch doesn't look like the correct one ;)
Comment on attachment 8643606 [details] [diff] [review]
Rebuild XPT files when the list of corresponding IDL files changed

Review of attachment 8643606 [details] [diff] [review]:
-----------------------------------------------------------------

Wrong patch for this bug.
Attachment #8643606 - Flags: review?(gps)
doh
Attachment #8643606 - Attachment is obsolete: true
Attachment #8643934 - Flags: review?(gps)
Attachment #8643934 - Flags: review?(gps) → review+
https://hg.mozilla.org/mozilla-central/rev/34a546e5ebe2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.