Turn off OSX/Windows B2G Desktop builds

RESOLVED DUPLICATE of bug 1208568

Status

RESOLVED DUPLICATE of bug 1208568
3 years ago
7 months ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Starting with ni? Gregor, but feel free to shift the needinfo elsewhere if need-be.

We don't run tests on OSX/Windows builds. We have Mulet builds running on both platforms (albeit opt-only at the moment) without tests now. Can we kill OSX/Windows B2G Desktop for good and save some build capacity?
Flags: needinfo?(anygregor)
(Reporter)

Comment 1

3 years ago
At Gregor's request over IRC, I've sent a note to dev-b2g and dev-gaia about this. Plan is to move forward on Friday if nobody screams.
https://groups.google.com/d/msg/mozilla.dev.gaia/sB5HV3Ng1I4/bcOLyB3PDAAJ
As discussed on list, we still use these for Simulator add-on builds today.

I'll discuss with :ochameau tomorrow about this.
Depends on: 1191868
Flags: needinfo?(anygregor)
Is there any bug regarding gaia test?
As said on the mailing list by Tim and Julien, build scripts need to be updated to pull mulet instead of b2g-desktop. Otherwise gaia developers won't be able to run tests locally anymore.
(In reply to Alexandre Poirot [:ochameau] from comment #3)
> Is there any bug regarding gaia test?
> As said on the mailing list by Tim and Julien, build scripts need to be
> updated to pull mulet instead of b2g-desktop. Otherwise gaia developers
> won't be able to run tests locally anymore.

Alex, do you know?
Flags: needinfo?(lissyx+mozillians)
(In reply to Alexandre Poirot [:ochameau] from comment #3)
> Is there any bug regarding gaia test?
> As said on the mailing list by Tim and Julien, build scripts need to be
> updated to pull mulet instead of b2g-desktop. Otherwise gaia developers
> won't be able to run tests locally anymore.

Technically I think the changes are mostly the same as we needed on mozharness for enabling Gaia tests with Mulet, i.e., instead of getting a B2G Desktop we get a Mulet built and then we extract it to Gaia's b2g/ and then just run the firefox/firefox binary from there.

That being said I'm not comfortable hacking this right now given there is ongoing work on those pieces. 

Aus, I know you are busy but I also know you are hacking around those pieces. Do you think you could do it? Otherwise I'll do it but it's not going to happen very soon.
Flags: needinfo?(lissyx+mozillians) → needinfo?(aus)
Once we have a download mechanism that works I can help for the bin/gaia-test script.
Depends on: 1194979
Flags: needinfo?(aus)
See Also: → bug 1208568
See Also: → bug 1171616
See Also: → bug 1171615
Ryan, do you know of any other dependencies that are not called out? Seems like we are good to go here.
Flags: needinfo?(jryans)
(In reply to Gregor Wagner [:gwagner] from comment #8)
> Ryan, do you know of any other dependencies that are not called out? Seems
> like we are good to go here.

No, I believe it is safe to proceed with disabling these builds now.
Flags: needinfo?(jryans)
This work was completed in bug 1208568.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208568
It seems to correctly builds, but the packages are not uploaded.
it fails during post-upload but there is no explicit error message:
Running post-upload command: post_upload.py --tinderbox-builds-dir mozilla-inbound-win32-mulet -p b2g -i 20151029043039 --revision cbe032ac35c235cbd9dbf7c7b2f13f60ead60a30 --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds
09:38:29     INFO -  Traceback (most recent call last):
09:38:29     INFO -    File "c:/builds/moz2_slave/m-in-w32-mulet-000000000000000/build/src/build/upload.py", line 328, in <module>
09:38:29     INFO -      package=options.package, verbose=True)
09:38:29     INFO -    File "c:/builds/moz2_slave/m-in-w32-mulet-000000000000000/build/src/build/upload.py", line 232, in UploadFiles
09:38:29     INFO -      output = DoSSHCommand('%s "%s" %s' % (post_upload_command, path, file_list), user, host, port=port, ssh_key=ssh_key)
09:38:29     INFO -    File "c:/builds/moz2_slave/m-in-w32-mulet-000000000000000/build/src/build/upload.py", line 96, in DoSSHCommand
09:38:29     INFO -      output = f(cmdline, stderr=STDOUT).strip()
09:38:29     INFO -    File "c:\builds\moz2_slave\m-in-w32-mulet-000000000000000\build\src\python\redo\redo\__init__.py", line 185, in _retriable_wrapper
09:38:29     INFO -      **retry_kwargs)
09:38:29     INFO -    File "c:\builds\moz2_slave\m-in-w32-mulet-000000000000000\build\src\python\redo\redo\__init__.py", line 140, in retry
09:38:29     INFO -      return action(*args, **kwargs)
09:38:29     INFO -    File "c:\mozilla-build\python27\Lib\subprocess.py", line 544, in check_output
09:38:29     INFO -      raise CalledProcessError(retcode, cmd, output=output)
09:38:29     INFO -  subprocess.CalledProcessError: Command '['ssh', '-o', 'IdentityFile=/c/Users/cltbld/.ssh/ffxbld_rsa', 'ffxbld@upload.ffxbld.productdelivery.prod.mozaws.net', 'post_upload.py --tinderbox-builds-dir mozilla-inbound-win32-mulet -p b2g -i 20151029043039 --revision cbe032ac35c235cbd9dbf7c7b2f13f60ead60a30 --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds "/media/ephemeral0/tmp/tmp.bRSqH775r7/" "/media/ephemeral0/tmp/tmp.bRSqH775r7//firefox-44.0a1.en-US.win32.zip" "/media/ephemeral0/tmp/tmp.bRSqH775r7/win32/xpi/firefox-44.0a1.en-US.langpack.xpi" "/media/ephemeral0/tmp/tmp.bRSqH775r7//mozharness.zip" "/media/ephemeral0/tmp/tmp.bRSqH775r7//firefox-44.0a1.en-US.win32.txt" "/media/ephemeral0/tmp/tmp.bRSqH775r7//firefox-44.0a1.en-US.win32.json" "/media/ephemeral0/tmp/tmp.bRSqH775r7//firefox-44.0a1.en-US.win32.mozinfo.json" "/media/ephemeral0/tmp/tmp.bRSqH775r7//jsshell-win32.zip" "/media/ephemeral0/tmp/tmp.bRSqH775r7/host/bin/mar.exe" "/media/ephemeral0/tmp/tmp.bRSqH775r7/host/bin/mbsdiff.exe" "/media/ephemeral0/tmp/tmp.bRSqH775r7//firefox-44.0a1.en-US.win32.checksums"']' returned non-zero exit status 1
There is a shorted error message for mac:

subprocess.CalledProcessError: Command '['ssh', '-o', 'IdentityFile=/Users/cltbld/.ssh/ffxbld_rsa', 'ffxbld@upload.ffxbld.productdelivery.prod.mozaws.net', 'post_upload.py --tinderbox-builds-dir mozilla-inbound-macosx64-mulet -p b2g -i 20151029043039 --revision cbe032ac35c235cbd9dbf7c7b2f13f60ead60a30 --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds "/media/ephemeral0/tmp/tmp.0m1jLv5Bon/" "/media/ephemeral0/tmp/tmp.0m1jLv5Bon//firefox-44.0a1.en-US.mac


See this run:
  https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=cbe032ac35c2&filter-searchStr=mulet&exclusion_profile=false
Flags: needinfo?(mshal)
(In reply to Alexandre Poirot [:ochameau] from comment #12)
> There is a shorted error message for mac:
> 
> subprocess.CalledProcessError: Command '['ssh', '-o',
> 'IdentityFile=/Users/cltbld/.ssh/ffxbld_rsa',
> 'ffxbld@upload.ffxbld.productdelivery.prod.mozaws.net', 'post_upload.py
> --tinderbox-builds-dir mozilla-inbound-macosx64-mulet -p b2g -i
> 20151029043039 --revision cbe032ac35c235cbd9dbf7c7b2f13f60ead60a30
> --release-to-tinderbox-dated-builds --release-to-latest-tinderbox-builds
> "/media/ephemeral0/tmp/tmp.0m1jLv5Bon/"
> "/media/ephemeral0/tmp/tmp.0m1jLv5Bon//firefox-44.0a1.en-US.mac
> 
> 
> See this run:
>  
> https://treeherder.mozilla.org/#/jobs?repo=mozilla-
> inbound&revision=cbe032ac35c2&filter-searchStr=mulet&exclusion_profile=false

:ochameau -- see bug 1218570. We have mac uploading again from b2g-inbound properly. We're adding the rest today.
Flags: needinfo?(mshal)
Is this related to the new upload host?
(In reply to Michael Shal [:mshal] from comment #14)
> Is this related to the new upload host?

Yeppers!
Great, thanks!!
Could you CC me on bugs when you are going to switch to S3 and/or TC?
(In reply to Alexandre Poirot [:ochameau] from comment #16)
> Great, thanks!!
> Could you CC me on bugs when you are going to switch to S3 and/or TC?

I've cc'd you and :aus on all the bugs related to the cutover.
(Assignee)

Updated

7 months ago
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.