OK/Cancel error dialog when sending mail should have more explicit buttons

VERIFIED DUPLICATE of bug 142737

Status

MailNews Core
Composition
--
minor
VERIFIED DUPLICATE of bug 142737
16 years ago
9 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: varada)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
STEPS TO REPRODUCE
   1. Reply to a message.
   2. Click Send.
   >  A dialog appears (this is probably server-dependent and doesn't always 
      occur even on my server, although it is quite frequent):
         The current command did not succeed. The mail server responded:
         Command unrecognised: UID SEARCH
   3. Click OK.
   >  Another dialog appears, note the capitalisation of "Sent folder":
         Your Send operation was successful, but copying the message to your 
         Sent folder failed. Would you like to return to the compose window?

The bug is: The buttons available are OK and Cancel. They should be "Return to
compose window" and "Discard Message". At the moment it is not obvious that
"Cancel" will cause dataloss.
(Reporter)

Comment 1

16 years ago
There should probably also be a button for "Retry", because for me it usually
works on the third or fourth attempt.

Comment 2

16 years ago
i'm marking this dupeme not because hixie filed a bug similar to this about a 
slightly different aspect (he filed many bugs about all possible aspects) but 
because i think there is an older bug about this (i might have filed it).
Whiteboard: DUPEME

Comment 3

16 years ago
Oh right, the other thing... retry would never work for me w/ the account that 
i have that can reproduce this bug, the sent folder doesn't exist, so it always 
fails to save :)

Comment 4

16 years ago
Jglick, isn't there a bug filed to revise this incredibly misleading and
confusing dialog?
-->Varada
Assignee: ducarroz → varada

Comment 6

16 years ago
Marking this as a dup of bug 28211. Both the bugs requset to let the user retry
when failing to copy to the sent folder.
Again jglick would make the call as to what the buttons should say.  

*** This bug has been marked as a duplicate of 28211 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

16 years ago
Reopening. This bug is about the buttons having the wrong labels, the other bug
is about the need for a retry button.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 8

15 years ago
The problems with the Cancel/OK response for this very dialogue is discussed in 
bug 142737. Unfortunately the discussion there doesn't seem to be moving 
forward to a resolution very fast.

Resolving as a dupe of 142737.


*** This bug has been marked as a duplicate of 142737 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 9

15 years ago
Okay, I can't keep track of which window is which. Its really (honest, this 
time) a dupe of bug 118684. Apologies for the spam.
Whiteboard: DUPEME

Comment 10

15 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.