Closed Bug 1191525 Opened 4 years ago Closed 4 years ago

Disable DXVA for massive videos.

Categories

(Core :: Audio/Video: Playback, defect, P2)

29 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

We currently disable videos higher than 1080p for AMD, but nothing else.

For really large videos (see URL) on other drivers, we attempt to use DXVA.

Since the GPU can't keep up, we start dropping frames immediately, and very quickly end up disabling hardware decoding (for the entirety of the session) as a result.

This is a really bad experience, as the first ~1s of the video displays almost no frames.

I think we should extend the 1080p limit to all GPU types, and possibly investigate being smarter about the GPUs capabilities.
Attached patch dxva-4kSplinter Review
Assignee: nobody → matt.woodrow
Attachment #8643985 - Flags: review?(ajones)
If we know that we will always use software decoding for 4K+ videos, is VP9 preferable to H.264?

jya said YouTube queries the mediasource to find out if we support level 5.1 (4K+). Can we return yes just for 5.1 with VP9? YouTube prefers to make their media decisions on the server side (using UA detection) to reduce users' time-to-playback latency. They also prefer to serve VP9 over H.264, so I'm sure they would be happy to work with us.

See also YouTube 8K bug 1176218.
Blocks: 1176218
Flags: needinfo?(ajones)
Attachment #8643985 - Flags: review?(ajones) → review+
This isn't a fix, it's just tinkering around the edges, treating the symptom and will end up performing even worse than the butchered DXVA implementation at the moment. Even a low-end Intel HD4600 is perfectly capable of playing 4k videos in IE11 and the Videos app on Windows 8.1+, go check for yourself.

Why can't you just fix the root cause of why DXVA/D3D11 performs like **** on Firefox compared with IE. It's these lazy and myopic decisions that lead to video decoding issues and to this "really bad experience" which drives people away from Firefox. For those who stay, there are some 300,000 people using Firefox addons that force the Flash player on YouTube videos. The addon's reviews are symbolic to the poor native DXVA implementation in Firefox.
It's just embarrassing.
The symptoms don't match but could this be the cause of bug 1095549 too?

(Doesn't the GPU driver provide the information on what's its limits for HWA decoding?)
(In reply to ... from comment #4)
> This isn't a fix, it's just tinkering around the edges, treating the symptom
> and will end up performing even worse than the butchered DXVA implementation
> at the moment. Even a low-end Intel HD4600 is perfectly capable of playing
> 4k videos in IE11 and the Videos app on Windows 8.1+, go check for yourself.
> 
> Why can't you just fix the root cause of why DXVA/D3D11 performs like ****
> on Firefox compared with IE. It's these lazy and myopic decisions that lead
> to video decoding issues and to this "really bad experience" which drives
> people away from Firefox. For those who stay, there are some 300,000 people
> using Firefox addons that force the Flash player on YouTube videos. The
> addon's reviews are symbolic to the poor native DXVA implementation in
> Firefox.
> It's just embarrassing.

I'm actively working on trying to do better in bug 1135935.

If you're interested in providing feedback then I should have builds available for testing soon.
Does this still need work, or can we close now that bug 1135935 is fixed?
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.