Nightly Icon on Windows 10 is Low resolution

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: mchang, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
The Nightly Icon on Windows 10 looks pretty bad, like a low resolution image. We should update it to a nice icon.
It looks fine to me (modulo the fact that the taskbar is generally smaller in Win10).

Can you share a screenshot and build number?
Flags: needinfo?(mchang)
(Reporter)

Comment 2

3 years ago
Created attachment 8646501 [details]
Desktop Screenshot

Sorry, I should've been more specific. It's fine on the taskbar, it's terrible on the desktop. The Firefox icon on release looks fine.
Flags: needinfo?(mchang)
I'm guessing you're on hi-DPI? The icon looks OK to me at standard DPI (even if I ctrl+wheel a little).
(Reporter)

Comment 4

3 years ago
Yeah this is a hi-DPI screen.
I'm going to take a page from Callek's book and flag dolske :)
Flags: needinfo?(dolske)
Yeah, I've noticed this too. I looked at it not that long ago, and suspected an issue with the ordering of the BMPs in the ICO. Both Nightly and the Official icons have 256x256 images available, but sometimes the order matters for reasons I don't recall. I think we ran into this last time we updated the Firefox icon, but from a light bug skim I don't see anything about it.

Steven, does this ring a bell with you?
Flags: needinfo?(dolske) → needinfo?(shorlander)
I think bug 901565 might have been when I was looking at it (specifically bug 901565 comment 8). Bug 499810 also dealt with some weirdness with ICOs in Windows CE -- *shudder* -- dunno if any of that is relevant here.
I can look into it. In theory it should just work like the official icon does. Could be some discrepancy in which tool was used to output the icon.
Is this still relevant with the new Nightly icon ?
Flags: needinfo?(shorlander) → needinfo?(dolske)
I see high-res icons (for both current Release and Nightly) on my Surface Pro, so things seem to be working as expected.

I don't remember running across this issue for a long time (and we've focused a lot of attention on hidpi issues since this was filed), so I think this can just be chalked up to occasional glitchyness from Windows. (At the very least, we'd need clear steps to reproduce to really do anything more here.)
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dolske)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.