Closed Bug 1191609 Opened 4 years ago Closed 4 years ago

Unwanted dark border is rendered

Categories

(Core :: Graphics, defect)

42 Branch
Unspecified
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla42
Tracking Status
firefox41 --- unaffected
firefox42 + verified

People

(Reporter: alice0775, Assigned: lsalzman)

References

Details

(Keywords: regression, testcase, Whiteboard: [gfx-noted])

Attachments

(4 files, 2 obsolete files)

Attached image screenshot (obsolete) —
[Tracking Requested - why for this release]:

This happens on Nightly42.0a1, but not on Aurora41.a2


Actual Results:
See attached screenshot
Summary: Unwanted dark border is rendered at top of tabbar on Windows7 Areo → Unwanted dark border is rendered at top of navbar on Windows7 Areo
Pushlog:

http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5490127f9b99&tochange=54c95895d377

Suspect: Bug 1185636
Blocks: 1185636
Severity: trivial → normal
Component: Theme → Graphics
Product: Firefox → Core
Flags: needinfo?(lsalzman)
I am having trouble seeing what the issue is from the attached screenshot, so I don't really understand what the issue is here. I would also need at least a before screenshot to even see what has changed rather than guess.
Flags: needinfo?(lsalzman) → needinfo?(alice0775)
(In reply to Lee Salzman [:eihrul] from comment #2)
> I am having trouble seeing what the issue is from the attached screenshot,
> so I don't really understand what the issue is here. I would also need at
> least a before screenshot to even see what has changed rather than guess.

Sure.
(But, I do not understand why not try it yourself)
Flags: needinfo?(alice0775)
Attachment #8644063 - Attachment is obsolete: true
Attached file testcase
Summary: Unwanted dark border is rendered at top of navbar on Windows7 Areo → Unwanted dark border is rendered
Keywords: testcase
Test this code patch out and see if it makes the regression go away. If so I can clean it up and make a more official version. I don't have a setup right now to build and test on Win 7 given the other work I am knee-deep in, so it's a bit painful for me to try it myself without pulling too much time form other tasks.
Flags: needinfo?(alice0775)
The testcase also reproduces this problem on Mac. It's a very visible regression, it needs to be fixed.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Whiteboard: [gfx-noted]
(In reply to Lee Salzman [:eihrul] from comment #6)
> Created attachment 8644124 [details] [diff] [review]
> quick hack to disable combining side stroke with corners
> 


I applied this patch to m-c tip and built locally.
The patch fixes the problem on Windows7.
Flags: needinfo?(alice0775)
(In reply to Alice0775 White from comment #8)
> (In reply to Lee Salzman [:eihrul] from comment #6)
> > Created attachment 8644124 [details] [diff] [review]
> > quick hack to disable combining side stroke with corners
> > 
> 
> 
> I applied this patch to m-c tip and built locally.
> The patch fixes the problem on Windows7.

Thanks. Then the regression must be coming from the fact that the border is being drawn with a fill sometimes now instead of a widened stroke. I'll make a better version of the patch and get it in.
This patch disables the combining of side and corner into one fill, which unfortunately does not seem to produce acceptable results with thin lines.

Now it should be closer to the old code which used a Stroke to draw the side, so the results should be similar again.

Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6786329698bf
Attachment #8644124 - Attachment is obsolete: true
Attachment #8644368 - Flags: review?(mstange)
Tracked for 42, so that the appearance is clean, consistent, and on-brand.
Comment on attachment 8644368 [details] [diff] [review]
Always stroke CSS border sides separately from corner fills

Yeah, this is fine. I didn't bother testing it because Alice and mchang already have, and because I don't have an up-to-date tree at the moment.
Attachment #8644368 - Flags: review?(mstange) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/7ae3e401ce99
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Alice, please confirm this is fixed in the next Nightly build.
Flags: needinfo?(alice0775)
I cannot reproduce the problem anymore on Nightly(2015-08-08)

https://hg.mozilla.org/mozilla-central/rev/943b79d9c65f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0 ID:20150808030207
Flags: needinfo?(alice0775)
(In reply to Alice0775 White from comment #16)
> I cannot reproduce the problem anymore on Nightly(2015-08-08)

Thank you very much for your help, Alice.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.