USB MassStorage dies claiming in the middle of the process

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
11 months ago

People

(Reporter: mcepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
I use rsync to synchronize my podcasts (downloaded via bashpodder from https://gitlab.com/mcepl/bashpodder.git) with the phone (unfortunately, no available podcatchers really work for me). Unfortunately, now with image v18D_nightly_v4 (and it as a problem even before with _v3) rsync quite often fails like this:

matej@mitmanek: ~$ rsync -rLtv --modify-window=1 --delete -P ~/.cache/bashpodder/downloads/ /run/media/matej/03CA-DD29/Music/Podcasts/
sending incremental file list
created directory /run/media/matej/03CA-DD29/Music/Podcasts
./
150802-cambridgesermon.mp3
    37726515 100%  115.59MB/s    0:00:00 (xfer#1, to-check=14/16)
180000.mp3
    25231360  76%    1.50MB/s    0:00:04
rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]: Broken pipe (32)
rsync: write failed on "/run/media/matej/03CA-DD29/Music/Podcasts/180000.mp3": Input/output error (5)
rsync: rename "/run/media/matej/03CA-DD29/Music/Podcasts/.180000.mp3.hoiT8g" -> "180000.mp3": No such file or directory (2)
rsync error: error in file IO (code 11) at receiver.c(322) [receiver=3.0.9]
rsync: connection unexpectedly closed (50 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(605) [sender=3.0.9]
matej@mitmanek: ~$ 

My biggest question I guess is to find out what I am doing wrong and how to work around it?
(Reporter)

Comment 1

4 years ago
Created attachment 8644299 [details]
logcat-2015-05-14-02.txt
(Reporter)

Comment 2

4 years ago
Created attachment 8644300 [details]
dmesg-2015-08-06.txt
(Reporter)

Comment 3

4 years ago
Computer side of the issue is https://bugzilla.redhat.com/show_bug.cgi?id=1251035

Comment 4

11 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.