Chrome file doesn't exist: .../NightlyDebug.app/Contents/Resources/chrome/toolkit/content/mozapps/preferences/preferences.css

RESOLVED FIXED in Firefox 52

Status

()

Firefox
Preferences
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: gfritzsche, Assigned: Gijs)

Tracking

Trunk
Firefox 52
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected, firefox52 fixed)

Details

MozReview Requests

()

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Running an m-c trunk build (as of 2015-08-06), i get the following in the terminal when looking at any preferences page:
Chrome file doesn't exist: /Users/gfritzsche/moz/mc1/obj/dist/NightlyDebug.app/Contents/Resources/chrome/toolkit/content/mozapps/preferences/preferences.css

The preference pages are accordingly broken, e.g. no nested Telemetry setting can be seen in the data choices.
Flags: needinfo?(jaws)
(Assignee)

Comment 1

2 years ago
From IRC today:

[19:28:21]	jaws	anybody here running a mac build right now?
[19:28:30]	Gijs	jaws: I can be, though it's a few days old - why?
[19:28:42]	jaws	Gijs: responding to a needinfo from https://bugzilla.mozilla.org/show_bug.cgi?id=1191778
[19:28:44]	firebot	Bug 1191778 — NEW, nobody@mozilla.org — Chrome file doesn't exist: .../NightlyDebug.app/Contents/Resources/chrome/toolkit/content/mozapps/pr
[19:29:07]	jaws	i'm doubting that it happens to others or else we would have seen a lot of dupes by now
[19:30:43]	Gijs	jaws: I don't see that but I do see that when I open the style editor
[19:31:00]	Gijs	which says "Style sheet could not be loaded. chrome://mozapps/content/preferences/preferences.css"
[19:31:47]	jaws	hmmm
[19:32:08]	Gijs	but I see that on Windows too
[19:32:29]	Gijs	I don't know what "no nested Telemetry setting can be seen in the data choices" means
[19:33:09]	Gijs	on a mozilla-produced nightly, I get the same error
[19:33:20]	Gijs	but I do see nested telemetry options
[19:33:29]	Gijs	I rather think that the CSS file is just a dead reference somewhere
[19:33:51]	Gijs	and the nested telemetry not being there is because it's a local build
[19:33:53]	jaws	Gijs: this is what nested telemetry setting is, http://screencast.com/t/lkdYf5sQx6Ic
[19:34:01]	jaws	oh
[19:34:01]	Gijs	yes
[19:34:02]	Gijs	I know
[19:34:20]	jaws	yeah i realized in your later comments
[19:34:23]	Gijs	NightlyDebug.app sounds self-compiled
[19:34:26]	jaws	yeah
[19:34:28]	Gijs	plus no omni.ja in that URI


So, in summary, I don't get the same thing in stderr/stdout, but that's maybe to do with me not running a debug build.

I don't think this is why you don't see the telemetry options - the same error happens on official nightly builds if you open the style editor (shift-f7) - but the telemetry options are visible just fine.

Georg, can you confirm this? We can remove the reference from wherever it ends up coming, but I don't think it's involved with any of the telemetry being there or not.
Flags: needinfo?(jaws) → needinfo?(gfritzsche)
Clearing old needinfo request and closing the bug as incomplete. Georg, please reopen the bug if you are still seeing this issue and can confirm it is not because you are using a debug build with telemetry not enabled/compiled.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(gfritzsche)
Resolution: --- → INCOMPLETE
(Assignee)

Updated

a year ago
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
(Assignee)

Comment 3

a year ago
The stylesheet was killed off in bug 459372 and then not removed from any browser/ code. Sigh. It doesn't actually break anything, it's just dumb that we're referencing it while it doesn't exist.
Assignee: nobody → gijskruitbosch+bugs
Blocks: 1304197, 459372
Status: REOPENED → ASSIGNED
Comment hidden (mozreview-request)

Comment 5

a year ago
mozreview-review
Comment on attachment 8795809 [details]
Bug 1191778 - remove references to mozapps content preferences.css stylesheet,

https://reviewboard.mozilla.org/r/81750/#review80398
Attachment #8795809 - Flags: review?(jaws) → review+

Comment 6

a year ago
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d2435513f135
remove references to mozapps content preferences.css stylesheet, r=jaws

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/d2435513f135
Status: ASSIGNED → RESOLVED
Last Resolved: a year agoa year ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
You need to log in before you can comment on or make changes to this bug.