TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\content-policy\test-general-content-policy.js | test-general-content-policy.js::test_generalContentPolicy

RESOLVED FIXED in Thunderbird 44.0

Status

MailNews Core
Backend
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
Thunderbird 44.0
Dependency tree / graph

Firefox Tracking Flags

(firefox42 affected)

Details

(Whiteboard: [fixed by bug 1193200])

TEST-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\content-policy\test-general-content-policy.js | test-general-content-policy.js::test_generalContentPolicy

04:13:30     INFO -  SUMMARY-UNEXPECTED-FAIL | C:\slave\test\build\tests\mozmill\content-policy\test-general-content-policy.js | test-general-content-policy.js::test_generalContentPolicy
04:13:30     INFO -    EXCEPTION: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIPermissionManager.add]
04:13:30     INFO -      at: nonesuch line 276
04:13:30     INFO -         checkAllowForSenderWithPerms test-general-content-policy.js:276 3
04:13:30     INFO -         test_generalContentPolicy test-general-content-policy.js:384 5
04:13:30     INFO -         Runner.prototype.wrapper frame.js:585 9
04:13:30     INFO -         Runner.prototype._runTestModule frame.js:655 9
04:13:30     INFO -         Runner.prototype.runTestModule frame.js:701 3
04:13:30     INFO -         Runner.prototype.runTestDirectory frame.js:525 7
04:13:30     INFO -         runTestDirectory frame.js:707 3
04:13:30     INFO -         Bridge.prototype._execFunction server.js:179 10
04:13:30     INFO -         Bridge.prototype.execFunction server.js:183 16
04:13:30     INFO -         Session.prototype.receive server.js:283 3
04:13:30     INFO -         AsyncRead.prototype.onDataAvailable server.js:88 3

Code:
  let uri = Services.io.newURI("mailto:" + authorEmailAddress, null, null);
  Services.perms.add(uri, "image", Services.perms.ALLOW_ACTION);

See bug 1173523 - Services.perms only seems to support hosts now. This should affect all mail address based permission management.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 29

2 years ago
Should get fixed by bug 1193200.
Depends on: 1193200

Updated

2 years ago
Duplicate of this bug: 1207547

Comment 31

2 years ago
At least locally still doesn't work for me after bug 1193200.
Locally forwarding a mail in the mozmill test crashes, but outside mozmill I can't reproduce. (checkComposeWindow for forward).

Comment 32

2 years ago
Appears to be fixed on the build machines :-)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0
Version: Trunk → unspecified

Comment 33

2 years ago
There is no failure in this particular test on the trunk servers. Also no crash to be seen.
Whiteboard: [fixed by bug 1193200]
You need to log in before you can comment on or make changes to this bug.