Foxfood: no preview when selecting ringtone

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Ringtones
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: aappleton@mozilla.com, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

See screenshot. 

When changing ringtone, there is no sample played.
(Reporter)

Comment 1

3 years ago
Created attachment 8644366 [details]
2015-08-06-15-35-12.png
QA Whiteboard: [foxfood-triage]
Component: Gaia::Feedback → Gaia::Ringtones
Keywords: qawanted, verifyme

Updated

3 years ago
QA Contact: mshuman
After 10 attempts, I was unable to reproduce this issue on the latest Flame and Spark 2.5 builds.
Selecting ringtones plays an audible sample properly.


Environmental Variables:
Device: Aries 2.5
Build ID: 20150810142756
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: cd45a38ded04
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5
Build ID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

leaving qawanted keyword for another tester to attempt repro.
QA Whiteboard: [foxfood-triage] → [QAnalyst-Triage?][foxfood-triage]
Flags: needinfo?(ktucker)
QA Contact: mshuman
QA Whiteboard: [QAnalyst-Triage?][foxfood-triage] → [foxfood-triage]
Flags: needinfo?(ktucker)

Comment 3

3 years ago
This works for me too (Flame 2.5).
I was able to reproduce this issue the first time I tried on Aries, but has not been able to do so again or on Flame.  Leaving the tag so someone else can try.

Reproduction Rate: 1/20 (10 on each device)

Environmental Variables:
Device: Aries 2.5
BuildID: 20150810155055
Gaia: fa89e03dc489e79baa0e74cb1d205260c7924caa
Gecko: 7a19194812eb
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150810030209
Gaia: 09dea2d5ff21cdb56da35fe4aa5bf4c90cf1da7f
Gecko: 0e269a1f1beb
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 42.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
I was also unable to reproduce this issue on latest Aries after multiple attempts. Ringtone gets played when selecting it in the preview panel. Removing qawanted due to inability to repro the bug on multiple parties; also removing verifyme keyword since nothing is being fixed here we're just unable to repro the bug.

Tested on:
Device: Aries (RC4 and OTA'ed to dogfood-latest)
BuildID: 20150811152431
Gaia: 9a8880a95ee4a4aea7895d4e2bcab31bc49ea281
Gecko: d82b5a78686a4f6630128fa7b999e0e343a9ef06
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [foxfood-triage] → [foxfood-triage], [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted, verifyme
QA Whiteboard: [foxfood-triage], [QAnalyst-Triage?] → [foxfood-triage], [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 6

2 years ago
Seems like multiple people are failing to reproduce this, so I'm guessing this was just one of the many audio playback issues Aries has faced. They seem to mostly be resolved now.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.