crash in xul.dll@0x212faf0 | mozilla::dom::quota::QuotaObject::Release()

RESOLVED DUPLICATE of bug 1185223

Status

()

Core
DOM: IndexedDB
--
critical
RESOLVED DUPLICATE of bug 1185223
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox42 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-835f1272-80fc-401c-8211-556ba2150806.
=============================================================
0 	xul.dll 	xul.dll@0x212faf0 	
1 	xul.dll 	mozilla::dom::quota::QuotaObject::Release() 	dom/quota/QuotaManager.cpp
2 	xul.dll 	`anonymous namespace'::xClose(sqlite3_file*) 	storage/TelemetryVFS.cpp
3 	nss3.dll 	sqlite3OsClose 	db/sqlite3/src/sqlite3.c
4 	nss3.dll 	sqlite3WalClose 	db/sqlite3/src/sqlite3.c
5 	nss3.dll 	sqlite3PagerClose 	db/sqlite3/src/sqlite3.c
6 	nss3.dll 	sqlite3BtreeClose 	db/sqlite3/src/sqlite3.c
7 	nss3.dll 	sqlite3LeaveMutexAndCloseZombie 	db/sqlite3/src/sqlite3.c
8 	nss3.dll 	sqlite3Close 	db/sqlite3/src/sqlite3.c
9 	xul.dll 	mozilla::storage::Connection::internalClose(sqlite3*) 	storage/mozStorageConnection.cpp
10 	xul.dll 	mozilla::storage::Connection::Close() 	storage/mozStorageConnection.cpp
11 	xul.dll 	mozilla::storage::Connection::~Connection() 	storage/mozStorageConnection.cpp
12 	xul.dll 	mozilla::storage::Connection::Release() 	storage/mozStorageConnection.cpp
13 	xul.dll 	NS_ProxyRelease(nsIEventTarget*, nsISupports*, bool) 	xpcom/glue/nsProxyRelease.cpp
14 	xul.dll 	mozilla::storage::Service::unregisterConnection(mozilla::storage::Connection*) 	storage/mozStorageService.cpp
15 	xul.dll 	mozilla::storage::Connection::Release() 	storage/mozStorageConnection.cpp
16 	xul.dll 	nsCOMPtr_base::~nsCOMPtr_base() 	xpcom/glue/nsCOMPtr.h
17 	xul.dll 	mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient::PerformIdleMaintenanceOnDatabaseInternal(unsigned int, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo const&) 	dom/indexeddb/ActorsParent.cpp
18 	xul.dll 	mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient::PerformIdleMaintenanceOnDatabase(unsigned int, nsACString_internal const&, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo&&) 	dom/indexeddb/ActorsParent.cpp
19 	xul.dll 	nsRunnableMethodArguments<unsigned int, nsCString, mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient::SingleMaintenanceInfo&&>::apply<mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient, void ( mozilla::dom::indexedDB::A0xee804eea::QuotaClient::*)(unsigned int, nsACString_internal const&, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo&&)>(mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient*, void ( mozilla::dom::indexedDB::A0xee804eea::QuotaClient::*)(unsigned int, nsACString_internal const&, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo&&)) 	xpcom/glue/nsThreadUtils.h
20 	xul.dll 	nsRunnableMethodImpl<void ( mozilla::dom::indexedDB::`anonymous namespace'::QuotaClient::*)(unsigned int, nsACString_internal const&, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo&&), 1, unsigned int, nsCString, mozilla::dom::indexedDB::A0xee804eea::QuotaClient::SingleMaintenanceInfo&&>::Run() 	xpcom/glue/nsThreadUtils.h
21 	xul.dll 	nsThreadPool::Run() 	xpcom/threads/nsThreadPool.cpp
22 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
23 	xul.dll 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
24 	xul.dll 	mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
25 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
26 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
27 	xul.dll 	nsThread::ThreadFunc(void*) 	xpcom/threads/nsThread.cpp
28 	nss3.dll 	PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c
29 	nss3.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c
30 	msvcr120.dll 	_callthreadstartex 	f:\dd\vctools\crt\crtw32\startup\threadex.c:376
31 	msvcr120.dll 	_threadstartex 	f:\dd\vctools\crt\crtw32\startup\threadex.c:354
32 	kernel32.dll 	BaseThreadInitThunk 	
33 	msvcr120.dll 	endthreadex 	f:\dd\vctools\crt\crtw32\startup\threadex.c:431
34 	msvcr120.dll 	endthreadex 	f:\dd\vctools\crt\crtw32\startup\threadex.c:431
35 	ntdll.dll 	RtlUserThreadStart 	
36 	kernel32.dll 	FSPErrorMessages::ReadDwordFromRegistry(void*, unsigned short const*, unsigned long*) 	
37 	kernelbase.dll 	OpenCustomLocaleKey 	
=============================================================

I hit this crash today soon after restarting Nightly from an update.
Jan, I feel like I've seen another bug about a crash here but am I mis-remembering?
Flags: needinfo?(Jan.Varga)
Very strange. We're attempting to execute a vtable directly rather than jumping through it as a pointer. It's like there's a level of indirection missing.

The assembly looks ok though so I don't think it's a code problem. More likely some objects busted in memory.

The hex offsets in the signature shift around, but as far as I can tell it's still rather low volume: https://crash-stats.mozilla.com/search/?signature=~QuotaObject&signature=%24xul&date=%3E4%2F4%2F2015&_facets=signature&_facets=build_id&_facets=version&_facets=release_channel&_facets=reason&_facets=cpu_name&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform

Comment 3

3 years ago
(In reply to Andrew Overholt [:overholt] from comment #1)
> Jan, I feel like I've seen another bug about a crash here but am I
> mis-remembering?

Yes, it's a dupe.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(Jan.Varga)
Resolution: --- → DUPLICATE
Duplicate of bug: 1185223
You need to log in before you can comment on or make changes to this bug.